Images not full size after export

I’m running windows 10. Shotcut version 20.07.11. Should be 64-bit, though doesn’t say in Help About.

After exporting, any still image where I have applied the Size and Position or Rotate and Scale filter does not appear correctly. Everything in that section of video that includes a still image with size and position filter is “squished” such that it does not fill the screen.

I am using a Custom Video size to make the video more “square” so that it appears (almost) equally sized when viewed on a phone held vertical or horizontal. Stats are showing that people are viewing vertical more and more, so I try to make my videos more equally viewable to users on phones as well as on laptops now.

As you can see in this screenshot, she appears to fill the whole screen when previewing.

But, after exporting the video is not filling the screen:

I had this problem with other PNG and JPG files in the project as well leading up the interview. They are all squished. During the transition from a squished “still” image to the actual video interview, the video is also “squished”.

But, as soon as the transition is done, the video pops up to fill the screen:

Obviously, this is not what I want, and when previewing it looks correct:

It’s only after exporting that the issue reveals itself.

If I remove the Size and Position filter, it does not squish.

What is your video mode? (Click on Output then click Properties)
Did you change any setting in Export - Advanced? If so, what did you change?

Custom video mode. I cropped my video down to be more square and then set the video mode to match.

image

I kept Resolution high, because otherwise FB flags it as not HD and they don’t show it as much. I hate FB’s social algorithms, but they are what they are.

Export mode I am using Default.

The resolution is the size of the video, which I’m guessing you want to be 1300x990, which is close to a 5:4 aspect ratio, but not quite.

When you enter into the export side of things, it morphs the mismatch of Resolution to Aspect Ratio. Granted you didn’t enter Advanced, but Shotcut changes this. I’m sure there is some reason why, as I’m sure the smarter volunteers in here could clearly explain.

Not sure there is an immediate fix to your project, so before attempting to start fixing your project, either copy your current save to a different location/file name, or Save As to a different file name.

Either attempt to fix this save or start a new project doing this.

Match Resolution of 1300 x 990
to Aspect Ratio of 1300 x 990

Then when you enter Export, it will export to 1300x990

When the resolution has a natural aspect ratio that differs from the aspect ratio override, the result is a video with non-square pixels, hence the stretch at playback. In this custom video mode, we have a natural 16:9 aspect ratio against a 130:99 override which forces a squish of the natural pixels to fit the overridden aspect ratio. Non-square is definitely not what Facebook prefers, and it also confuses the resizing filters about how much stretch to apply to an image. Aspect ratio override cannot be used to create a crop because all image pixels by design are forced into the overridden aspect ratio rather than eliminated.

A better way to create square video and still be considered HD is to set the resolution to square dimensions rather than hack the aspect ratio. In your case, set the resolution to 1080x1080 and the aspect ratio to 1:1. This works because “HD” is determined by the height, not the width. Use the same dimensions for the export settings if using the Advanced panel (although it should pre-fill those values automatically based on the Video Mode). In essence, the crop happens at the resolution level rather than the aspect ratio level. For convenience, Shotcut already has two built-in 1080p square video modes: Settings > Video Mode > Non-Broadcast > Square 1080p 30/60fps.

Unfortunately, any projects built with the 1300:990 aspect ratio will probably have to be rebuilt from scratch. It’s possible to change the video mode on a project in progress, but it would likely involve reconfiguring every Size & Position filter for the new mode, which may or may not be as much work as starting over. Sorry for the bad news.

@Hudson555x Great explanation. I didn’t see you were typing at the same time I was.

1 Like

Why does the main video work just fine then? Some things show up just fine in preview and export just fine, while others don’t.

Also, “non-square is definitely not what Facebook prefers”… Is that double negative the same as, “square is definitely what Facebook prefers”? Either way, I’m trying to get close to square simply to ensure that portrait vs landscape viewing get somewhat equal screen usage.

Shotcut has auto-conversion to match videos with different aspect ratios. You’ve also added “Crop: Source” filters that help make wide videos fit the square timeline. This is what causes video without Size & Position filters to look okay.

When Size & Position filters are added, things have potential to go haywire depending on whether the size mode is set to Fit, Fill, or Distort. Some of these could appear exaggerated due to non-square pixels.

Based on your second screenshot that is horizontally stretched, it also appears that the video player being used is not properly applying the 1300:990 aspect ratio like the Shotcut preview player is. If the media player was processing the video correctly, it would be square rather than wide.

Try bringing the exported video back into Shotcut and see if Shotcut plays it correctly in the Source window. If so, then the media player being used doesn’t understand aspect ratio override. This is another somewhat common problem with using non-square pixels… player support is not guaranteed.

Yes. The aspect ratio override is there to support older formats like anamorphic DVD. For modern formats, the resolution’s natural aspect ratio and the override aspect ratio should match.

Having true square resolution with 1:1 aspect ratio will get you there. If you want the 5:4 look, then use 1350x1080 with an aspect ratio override of 5:4. (1350 is five-fourths of 1080.) Note that 1300x990 will not get tagged as Full HD because the height is still less than 1080.

Also, thanks for including so many screenshots in your first post. Extremely useful to help figure out what’s going on.

Thanks for the help! Another interesting thing happening. I somehow got a good export… and now I can’t get it again. Not sure what change I made during that test run. But, I did get it to work finally and published the video:

Not sure why I can’t reproduce the success now. Wanted to make a small change and all further exports are wonky. going forward I’ll go with a more standard video size. I was trying to just make the subjects fit the frame better… I didn’t shoot the video, it’s off of Chrissie’s iphone she had mounted on a tripod. I just do the editing, but I sure wish I was doing the filming so i could get it framed correctly during the actual shoot!!! (as the husband though, I just do what I’m told! :grin: )

thanks again!

dave

2 Likes