Images in video are all white

What is your operating system?
Manjaro Linux x86_64

What is your Shotcut version (see Help > About Shotcut)?

Can you repeat the problem? If so, what are the steps?
I have been using Shotcut for a while (thank you for making this great tool). One problem that started yesterday, after upgrading my system from Linux kernel 6.3 to 6.4 is that all images in old and new project show up as white.

And, immediately after publishing this post I discovered a way to solve this. For the images / media items, I can choose properties > track and change the track from mjpeg to none. Then the images show up again.


How did you install Shotcut?

I can choose properties > track

That tells me the image loaded incorrectly. Shotcut is supposed to use Qt to load images, but it is failing and using libavformat (FFmpeg) instead, and that does not work correctly as you observed.

1 Like

Thanks for getting back to me, @shotcut!

I installed Shotcut using Pamac (from Arch Linux - shotcut 23.06.14-1 (x86_64)).

With the latest update of my system, which was a big one, Qt was updated, as well as FFmpeg.

$ qtdiag
Qt 5.15.10 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 13.1.1 20230429) on "xcb" 
OS: Manjaro Linux [linux version 6.4.3-1-MANJARO]
$ ffmpeg -version
ffmpeg version n6.0 Copyright (c) 2000-2023 the FFmpeg developers
built with gcc 13.1.1 (GCC) 20230429

There is the problem.

Qt 5.15.10

This is what is installed on your system, but Shotcut 23.x.y requires Qt 6.4 at a minimum.

You can get a proper working build through our download page.

1 Like

In the package page you listed above, it does not have a dependency on qt6-imageformats so maybe that is not installed: Arch Linux - qt6-imageformats 6.5.1-1 (x86_64)

P.S. And it has a dependency on qt6-websockets which is no longer required.

1 Like

Thank you, @shotcut!

I still have the problem after installing qt6-imageformats.
But I found that installing qt6-5compat solves the problem.
Archlinux: qt6-5compat

1 Like

An update, as I tried the Linux AppImage version. Using the AppImage the images did not show up at all. I assumed this is due to me having set the track to None.


So, I tried changing the track back to mjpeg. However, that resulted in a core dump:

[swscaler @ 0x7f20320000c0] Value 0.000000 for parameter 'srcw' out of range [1 - 2.14748e+09]
[swscaler @ 0x7f20320000c0] Value 0.000000 for parameter 'srch' out of range [1 - 2.14748e+09]
[IMGUTILS @ 0x7f206ca86310] Picture size 0x0 is invalid
/tmp/.mount_shotcuMbspRR/usr/bin//shotcut: line 21: 2925760 Segmentation fault      (core dumped) bin/shotcut "$@"