Image resizing is exporting distorted

After the most recent update, I’ve noticed I can’t resize an overlay image (JPG or PNG) without it becoming distorted. I’ve tried resizing it outside of Shotcut to both large (1920x1080) and small (96x82) but it makes no difference. I’ve tried recreating the image with no luck

It’s basically a video thumbnail designed to only take up about 5% of the screen

Theoretically, a larger image should scale down with no problem and I must emphasize that this issue has only occurred since the last update. Prior to that worked perfectly

The attached image is 220x220 pixels so it should size down to a clean image without jagged edges

Please help

Quick note, the issue occurs in version 18.08.11. I will download Ver 18.08.14 and report back on this issue

Yep, same issue in version 18.08.14, please help

It appears you have a filter applied to the Master track.

Click on the actual image clip and apply Size & Position filter to adjust size.

No luck I’m afraid.

Click where is says Master, then click Filters. What filter(s) do you have applied?

Click on the 220 image, what filter(s) do you have applied?

Only size and position. I’m not sure why there was a filter applied to the master track but I removed it and applied one to the actual image. No luck

I also rebooted Shotcut and created a test project from scratch. Applied a single “size and position” filter to the image and scaling down left the same jaggered image behind…

Can you upload your test mlt file and image? Just drag and drop in the reply box.

The Google logo used is 2000x2000 so it should be able to scale down without the rough edges right?

There are different algorithms for image scaling also know as “interpolation” (or lack of in the case of nearest neighbor). You are only viewing the results in the app preview, which follows Settings > Interpolation. What is your’s set to? Export has its own interpolation setting, which can safely be set to something different (and often should be). Did you export and view the result?

One thing that has changed in recent versions are corrections for something called premultiplied alpha (channel). Unfortunately, nearly all file formats do not signal premultiplied alpha, but either follow conventions or established by the standard. PNG does not use premultiplied alpha, but I see in both of your screenshots that you are using PNGs converted from SVG, and there might be something going on there. Provide the image you are using outside of a screenshot.

Interpolation is set to nearest (fast). Would there be an advantage to using a different image file/format? (JPG I’ve tried but no luck).

As a temporary solution, I wound back to a previous version of Shotcut through the properties settings

Here’s the image

(Quick sidenote) are there any typical triggers that cause MLT files to freeze upon loading? This hasn’t usually been a problem but after the recent update, a fairly big file (70kb) has been crashing like crazy. Had to chop it up into smaller bites and resave into smaller files to being able to load and export

That is expected to be jaggy because it does not interpolate. That is why it says “fast” and the other options indicate better quality. Try a different option especially in Export (not File > Export Frame… as that uses the preview setting).

JPG does not carry alpha channel.

Here is how it looks in v18.08 with bicubic interpolation in app preview:


Compared with v18.03 also using bicubic:


The newer version looks better due to the premultiplied alpha fixes. Look at the left edge of the gold segment in particular as well as the top edge of the red segment.

Also, when doing an evaluation or comparison in app preview, change the shotcut player zoom level to 100% to prevent looking at additional scaling incurred to “fit” the image within the preview area. My screenshots of the preview area above were made by doing that and using the Windows Snipping Tool.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.