Image not rendering

I love shotcut and it’s my editor of choice but after this bug I may have to start using something else because it just doesn’t make sense.

I have spent hours editing a video with multiple sources and file formats. Everything looks great, I export it, give it a final look before uploading to youtube, and one of the images is missing. I have 5 images from my phone on the timeline, they are pretty similar but just this one doesn’t render. Video shows the previous static frame where this file is supposed to be and then goes on to the next cut.

I have tried copying the project, removing, saving and adding the file, all while running as administrator, copying and renaming the file and adding it again - nothing works. I looked at the job log - there is nothing related to this file. I’m trying to render with GPU on (previously all rendered with GPU off) to see if it changes anything because at this point I’m out of options.

I have rendered the file at least 6 times and I have the same issue. I might have to do all my edits in another editor now, what a waste of time because of just one file

Try this:

  1. Start a new project
  2. Open image
  3. Export (default settings) (This creates a short 4-second video)
  4. File → Export → Frame (This creates a still image of the frame you have displayed)

Don’t apply any filters, and no need to use a timeline or the playlist.
Does your image render now?

If not, perhaps you could share more details of this image. Click on Properties.

  • What is the file extension?
  • Resolution
  • Pixel aspect ratio

Is the image file on your phone, or on your computer? If on your phone, try copying the file to your computer then try rendering again.

Sometimes filenames and folder names with special characters cause issues.

Thank you for the recommendation. The file was copied from my phone to the project folder where all project assets were. There were 4 other files just like this one and they all rendered perfectly well.The file is a Jpeg, 12 MP I believe. With that said, on attempt 8, when I had GPU rendering enabled it finally rendered it correctly. Go figure…

There were bugs in the past based on either the OS (some Linux) or JPEG size (v23.05) that should be all working in the latest version 23.06 on any OS.

Great to know. I’m on version 22.12 on windows and the file in question was bigger than the other ones that worked. I will update to the latest version, thank you

This topic was automatically closed after 90 days. New replies are no longer allowed.