Image creates a black background that cannot be removed. Should be able to see the image overlaying the video

I’m trying to place an image on top of a video. The image has no background, but once imported, a black background is automatically created. I’ve tried chroma key, switching up layers, etc. and nothing works. I’ve seen others have the same problem, but the measures they go to solve it are never the same and are unnecessarily complicated for such a simple problem. I’ve tried their methods but to no avail. I really need to get this video edited soon so any help would be immensely appreciated.

What is the filter that is on Output?
Do you have any filters on the PNG clip? if so, disable them all. If you used Rotate and Scale or Size and Position and change the Background color, you probably made it opaque.
What is the Blend mode in Properties for V3?

The filter is Chroma Key, with black as the key color. I went ahead and removed it as it obviously wasn’t doing much. No filters on the PNG. The blend mode is “Over.”

I do not know what you are doing wrong. It works for me:

From the timeline thumbnails, it does not appear that the image has black bars on top and bottom in its source. They are added because the aspect ratio is different than the project, but they should be added as transparent bars. As you can see it works for me. Most people need to control the size and position of the image too. Try removing the PNG and track V3 if nothing else is on it. Then, add V3 again and the PNG. Next, add the Size and Position filter to the PNG clip.

Hmmm. It still isn’t working for me. I’ll try to export what I have now (minus the png) and edit it as another project.

You might have GPU Effects enabled (see top of Settings), which is not supported. That was the only way I reproduced this.

This image: what kind of file is it?

I suppose you have to convert it to i.e. a tiff-file and import the tiff-file in the movie.

This is probably a duplicate of Black background with image overlay
which was solved with a few workarounds.

This is fixed for the next version 20.09


This topic was automatically closed after 90 days. New replies are no longer allowed.