If first Video Start time > 0, second video compolyety sped up

What is your operating system?
Win 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
build-shotcut-windows #913; Shotcut version 23.01.22

Can you repeat the problem? If so, what are the steps?
To make things easier I will use symbols for the different videos.
X: video with video track start time 00:00:02 (so above >0, have only used the same video for this,
idk if it would behave differently if i had one that starts at 3 one at
Y: video with video track start time 00:00:00 (different videos tested, just has to start at 00)

So if the first video added to shotcut is X, the Y videos you add to shotcut after that are all very sped up (audio and video), but if I would add multiple X videos the X videos would be normal. This behavior persists until I exit and reopen shotcut, meaning I can remove all videos from shotcut but when I add an Y track it would be still sped up.

The timeline doesn’t show that they are sped up but when u play it in shotcut or export it they are.

If the first video added to shotcut is a Y video, there is no problem, everything works fine.

This behavior occurs only if the first video added is a X video, afaik. And if the first video is the X video, all Y videos after that are sped up, all X videos after that are normal.

The X video: https://user-images.githubusercontent.com/1146683/213943766-e1878e6a-3e62-454b-b0b5-e8d1f594592a.mp4

For Y video you can use anything u have that has video track start time at 00.

Small Demonstration.

I am not completely sure here, i have another video which I think both audio and video track start at 00 but acts just like the X video, I will call it Z here. So will post them here and u guys can play with it :smile:



I did not reproduce exactly this in preview even when using your clips and the same version (usually we do not accept bug reports against unreleased versions). However, I did experience severe problems with the export even with parallel processing turned off. I did not reproduce it in the latest release version with export. Returning to the preview, I now see that even tho clip X plays to near the end where you can observe if there is a sync problem, in the timeline I cannot even though the full clip was included! It appears that video is running at half speed. A hand gesture I see at around 22sec in Source appears around 45sec in Timeline.

@brian I believe this is due to your change for sample rate conversion even though everything is 48 KHz (or that echo audio fix). This is based on testing various nightly builds. 23.01.03 has this bug whereas 22.12.25 does not.

@alc Use version 22.12.25. It contains the audio/sync fix and does not have this new bug.

I recreate this in Windows but not Linux. I’ll see about getting my Windows development environment up to date.

This is fixed for the release. Testing would be appreciated.

Thanks @brian. It is working fine now.