Iconv failed to convert "_mlt_properties_parse_yaml" from UTF-8 to code page 1252

Hello - fairly new user here. On one of my first projects the export/encoding job generates the following error
"iconv failed to convert “_mlt_properties_parse_yaml” from UTF-8 to code page 1252"
the job stays in pending status and i see this message by looking in the job Log

Seems to be a problem with the XML encoding … ? Any ideas what I can do to work around it ?
I’m running Shotcut version 16.07.01 on Win10 64bit

Thanks, Pete

What language/region setting are you using in Windows? What is the path where you installed Shotcut?
You can also send the application log (in view menu) after startup to answer these questions.

This bug is probably related

Thanks for the reply - I’m in the UK, nothing unusual in locale settings that I can see

[Info ] <Application::Application(int&, char**)> Starting Shotcut version 16.07.01
[Info ] <Application::Application(int&, char**)> Windows version 192
[Info ] <Application::Application(int&, char**)> number of logical cores = 4
[Info ] <Application::Application(int&, char**)> locale = QLocale(English, Default, UnitedKingdom)
[Info ] <Application::Application(int&, char**)> install dir = “C:/Program Files/Shotcut”
[Debug ] ShotcutSettings::singleton language “en_GB”

I’ve uninstalled Shotcut then reinstalled latest version with option to remove registry entries
Also - created a new project, containing just one file

Unfortunately that did not help - still have the same error when trying to Export

Thanks, Peter. I am not sure what is going wrong. I am going to increase the logging around this error and give you a new build to test tomorrow to hopefully reveal something.

I tried some new projects using different sources
If it’s an iphone mov file as the source, I don’t get the error. But all my GoPro footage seems to generates the error. I selected ''youtube’as the output format for each
I need to do some more empirical tests, but am going away for the weekend so not sure I will have time in the next few days

That is discouraging because it only adds to the strangeness of the problem. This function that reports this error is only called under very special circumstances that has nothing to do with video formats.

Here you can download a new version with an increased logging detail for that error. Hopefully, it can shed some light:


Thanks - I’ve installed the new version and launched it, then tried to export the original project which gives me this error
Same error occurred, and I’ve attached the Application Log and the Export XML and Export Log for the failed job.

I’m away camping with the family for the rest of this week, so I’m sorry that I won’t be able to perform more tests for a while. thanks for your help.

shotcut_exportlog_20160725_1917.txt (181 Bytes)
shotcut_exportxml_20160725_1917.txt (16.2 KB)
shotcut_applog_20160725_1917.txt (20.3 KB)

From your export XML, your timeline is empty yet you chose to export the timeline. That might be a hint for me about how to reproduce it. For this project, perhaps you added some things to the timeline and then removed them, or the export panel’s check for a valid timeline is not good.

In any case, at the top of the Export panel, change From to Playlist and try again. Or, if that is what you already did, and this is what happened, please confirm.

Enjoy your camping. :slight_smile:

Oops, my bad ! You are right, I had selected export from Timeline instead of Playlist
I made another attempt, this time selecting from playlist. I still got the same error in the log, but the conversion process started successfully. Very strange. It’s quite possible I have been mistakenly selecting timeline in the other attempts (in which case I blush and apologise for wasting your time) But why would I get this error ?
Anyway, here are the logs …

shotcut_exportlog_20160725_1957.txt (181 Bytes)
shotcut_exportxml_20160725_1957.txt (15.5 KB)

For the next release, I made some changes to try to prevent this. There is still a case where Timeline will show in From immediately after removing all tracks, but after a little activity the combo is refreshed and this option goes away.
I have not been able to figure out why you get this error, but I did also make a change to not log an error when the string is null - as that case should be a pass-through operation for this function.