I lost everything

I edited a video for 3 days straight, I have a good pc. The video couldn’t export for some reason, it was stuck at 0% for a while with no time estimated to export it. I saved the file as a project so the mlt thing. I restarted my pc and tried to open the mlt as a clip and it opened after a few minutes. I then proceeded to export the clip and it exported it as an mp4 as I wanted but then when I opened it it just said INVALID through the whole 15 minute video and there was nothing except the INVALID screen. I wasted so much time for nothing, thanks Shotcut. I still have the mlt project but I told you when I export it it just says invalid through the entire video. PLEASE HELP I’VE EDITED FOR SO LONG.
Edit: Now it doesn’t want to open as an mlt clip it just loads forever.

We don’t know what are the specs of your PC, so even if think that your PC is good, it might be low powered for your project. But here I think the specs doesn’t matter, it’s related to shotcut.

What version are you using of shotcut (Go to Help>About), this was also discussed in this topic

The project was trying to contain itself in that

You should go to View>Application Log and see for some errors there and this might help, also check the log file of export, by right clicking the export job and then click view log.

Are you running a file type that is not supported by shotcut?

I’m running the version 21.05.01 of shotcut.
I saved the project I made as a .mlt file which shotcut automatically saves projects to. Then I restarted my computer and opened shotcut first, then opened my project as a clip and in the editor it showed and worked properly. So it was playing in the editor but as soon as I exported I got hit in the face with the INVALID screen and it lasted for the whole duration of the video.
I’m just trying to export a normal video everything is supported and I just can’t.

Here is my application log if that helps, I’m indeed a noob at this program so I don’t know what it means.
aplog.txt (32.1 KB)

I am not a log expert, everything I am writing now is a pure guess:-

<LeapNetworkListener::onDisconnected> Disconnected from Leap Motion [Debug ] <LeapNetworkListener::onError> Leap Motion WebSocket error: "Connection refused"

I don’t know this is the error or not, but it could be something related to the problem you are facing. And the version you are using is reported unstable, you should try to open your .mlt in version 21.03.21 (The most stable version now).
Hope that this would help, I am also a end user of shotcut like you, So I would be wrong at many points if talking about log files, but log files shows about the filters and errors happened in the project.

Experienced users here can provide you the exact error in your project, I am not a noob at this program, but a end user of it.

The version you are using is highly bugged and not stable. Within days of release of this version the download page was changed to suggest the prior version 21.03.21 to be used in it’s place.

It might be possible to salvage your project file you just upload the MLT here. No guarantees though.

If you have moved media files from their original locations this will cause the INVALID screens to pop up. Read here (scroll to Missing Files) on how to fix this situation.

When exporting it may stay at 0% for a while as this is normal as Shotcut tries to estimate a remaining time. It’s not highly accurate, but as the export happens the time get’s more and more accurate. If you’re exporting to a HDD (Hard Disk Drive) vs. a SSD (Solid State Drive), then it may take even longer at 0%. You didn’t state any length of time that you waited. It’s also known that certain anti-virus programs can and do block Shotcut’s export program.


Upload your project file to a reply here.

P.S. The log message about LeapNetworkListener is normal and no cause for alarm.


so should I upload the mlt file I want to put on youtube here?

I’ll post it tomorrow morning around 11 uk time appreciate the replies and time you took to help me, I suppose you’ll try to export the mlt yourself and then resend it in an mp4 format?

Yes. Start a new reply here on this thread and drag the mlt file in the message.

They won’t be able to export your project since they won’t have all your other files (videos, images etc…)
But they can check the file and fix it if possible.

1 Like

okay thanks for the help I’ll reply with the file now

aa.mlt (186.9 KB)

I did not find any problems in your aa.mlt file. Please upgrade to the latest version from here to get off that known buggy version:

As mentioned elsewhere INVALID usually means some files it uses were moved or removed. When you open the project it might show a dialog saying files are missing. You can get read more about that here:

1 Like

Okay, how do I know if the files were moved and how do I move them back? Sorry for being annoying but I really don’t want to lose the project I made.

Look in the Shotcut application log file (menu item View->Application Log. You should see the names of the files that could not be found, but only you know where you moved these files to.

I haven’t moved anything except the mlt file which I then proceeded to return back to it’s original place.

Thanks for the new version, now everything works just fine. I really don’t know why it didn’t work in the previous version. I’m gonna stay editing with your program because you have such a nice community and you helped when I called.

As an old timer and a longtime Shotcut user, I can tell you that you will not be disappointed. I use several video editing programs, but Shotcut is the one I always come back to.
Shotcut is a very actively developed program, so some versions may have temporary problems. What I have done for a long time is to keep several earlier versions on the different systems I use, and not to rush to the new versions when they don’t bring features I don’t need…

Looks like the problem has been solved, but there’s a misunderstanding that should be corrected to avoid the OP further pain in the future:

The .mlt file does not contain any videos!

The .mlt file consists entirely of a set of instructions to tell Shotcut how to process your original video files to produce a new one. This processing only happens when you hit “export”.

That means that the .mlt alone is not worth anything: You cannot just send the mlt to somebody, and you also need to keep all the source material around until you are sure that you will not want to edit any more.

This is all explained in full detail in the post: Project Management.