How to voiceover in sc 18.07.02 with linux mint cinnamon 19

Viewed a tutorial for voiceover in Shotcut that said to File>>Open Other and select Direct Show. In the latest version of Shotcut…18.07.02…Direct Show is not an option and I see nowhere to choose my microphone to do a voiceover. Anyone know the new method for this version?

Shotcut 18.07.02. DirectShow is available.


Not in my version. Here is a screenshot of what “Edit>>Open Other” gets me. Perhaps because I am running the linux version? n If so, what is the solution?

Apologies. I assumed you were using Windows. Usually Linux users specify that they are using Linux in their post.

I just tested ALSA Audio and it worked for me.

BTW running Fedora in Vmware so what worked for me might not work for you.

That doesn’t work for me…I’m running Linux Mint Cinnamon 19. Its not even offering a selection of input devices, and when I accept “default” I just get a high pitched whine in the earphones.

This is something one of the developers might be able to help you with.

Linux and audio are a bit difficult to set up. You might try to install Audacity and use it to record audio for the voice over until you figure out to get Shotcut to work.

It might help if you include Linux in the subject. Might get one of the devs to respond.

I’ll go back and see if I can edit the title to add “linux”. As for using Audacity, I’ve got another workaround…I routinely use a digital voice recorder to record audio when I’m shooting multi-cam videos…I’ll just record the voiceover on it and lay down the new track. Its a shame to have to do that though.

That’s a solution until you can figure out how to get it done with Shotcut.

I find Audacity very useful when doing voice over. While I know that I could do voice over with Shotcut, I never used it. It’s just one of the many tools I use to make videos.

That is an alternative, but a poor one. Switching projects, or pieces of projects, back and forth between different versions is cumbersome and not very efficient. Each new version of SC should IMPROVE workflow, not hinder it.

I’d probably go with your solution (until there is a fix IN SC) if I wasn’t already used to using a digital voice recorder with a lavalier mic when I’m doing multi-camera shots.

I wouldn’t call it a solution. Audacity with all of it’s tools and filters is just amazing. I do use a number of filters.

If you are still using ALSA that might be your problem. I believe Mint sets up PulseAudio by default. So, you should be using that. Then, Mint settings or a PulseAudio control app (pavucontrol) to set recording device/input.

I appreciate the input but…It didn’t work. I installed pavucontrol, restarted the system, opened a project, selected

“Open Other>>PulseAudio” and still was not given a dropdown of devices to select from. I chose “OK” to select the default and got the same as before…a steady, high pitched whine with a static sound over the top of it.

What else?

That is by design. With PulseAudio you need to use the OS or pavucontrol to configure the audio input device.

PulseAudio works for me. When you open an audio device in Shotcut, it goes into a monitoring mode - you can hear what is coming in through the microphone. Maybe you are hearing feedback that occurs when the input level is high enough, the speakers are loud enough, and the microphone is close enough to the speakers.

I got rid of the whine and static…now I hear myself in the headpones (2-3 second delay) so I know the system is hearing me, but I see no indicator I am being recorded or, if I am, where the recording is being saved.

You are not. Re-watch the tutorial:

Hint: click Export, choose audio/WAV preset, click Capture File.

I should have responded DAYS ago, and didn’t. Thanks for the tip…It worked and is much appreciated.