How to upload high quality videos in youtube?

Hey guys, what preset do you use when exporting videos for youtube?

Yesterday I edited and exported a video clip (1080p@60). The quality was really good, but when I uploaded it to youtube it compressed it and made it much worse.

Is there any way I could upload a video to youtube and keep its quality?
I have seen video clips with crisp quality in YT? How they achieve this?

My settings:

Are the settings fine? Did I make something wrong?

Try exporting as 4k in Shotcut, upload as a private video to YT to check the results.

1 Like

But the video is recorded on 1080p?

Yes. Give it a go. Others may recommend other ideas. I have uploaded to YT with 1080p and the results were poor. Same video exported with 4K and uploaded to YT improves the quality. I think this has been discussed on the forum before, a quick search will probably show that thread.

For a start, you appear to be using hardware encoding. Unless you have a 7th-gen NVENC GPU like Nvidia RTX 20xx or higher you should ensure that Export panel > “Use hardware encoder” is NOT checked. Hardware encoding is used for speed of encoding, not quality. It will produce a much bigger file, with lower quality than software encoding.

Secondly, you have Qulaity set at 55% (quality val = 23), set it higher to around 67&, which should produce visually-lossless encoding, i.e. a video that looks to the human eye as if it is not compressed at all. Setting a higher value is not a good idea.

1 Like

@PaulusMaximus Ok, I’ll make a try.

I have RTX 3070.
I’ll try with 67% quality, but when I exported the video with quality 55% it was looking good and when I ran it with a video player on my PC it was OK.

The moment I uploaded it to YT, the quality drastically dropped.

Youtube transcodes the videos you upload, so it will compress the video. Compressing a video that is already compressed will always produce a poorer visual result. The less compression (like visually-lossless) you provide Youtube with, the better the final result.

For an overview see here:

1 Like

I just saw that you are encoding at 1080p. If your FPS is too low, Youtube will re-encode using AVC, rather than the better quality codec VP9. You will need to encode with at least 50fps. See here for more info (but be aware, Youtube changes their policy frequently and what worked last week may not work this week):

@Elusien I encoded it on 60 fps. I’ll check that posts as well. Thanks.

YouTube is a moving target. But the last I saw, any video submitted at 1440p or higher resolution was encoded directly to VP9. Often it’s the same bitrate, but looks like higher quality from the same bitrate thanks to VP9. I think higher bitrates are possible, but reserved for popular channels.

Since your source is 1080, this means keeping the video mode (timeline resolution) at 1080p. Then on the Export > Advanced panel, change the resolution to 1440 or 4K, and set the Interpolation mode to Lanczos. This will provide the most crisp upscale from 1080 to 1440+.

This sounds hacky, but it’s actually pretty common.

Yes, it looks like my video is reencoded to avc…

Thanks guys, I’ll try to upload my next video with 1440p res. :slight_smile:

This topic was automatically closed after 90 days. New replies are no longer allowed.