How to keep vid in correct aspect ratio

I’m finding that when I add toolbars when working in the timeline I start losing real estate on the preview screen. I’d like to know if the screen can be kept always full visibility when editing the timeline.

I don’t know what you mean “toolbars” or “real estate”. The scopes and widgets in Shotcut can be popped out and back into the main window again just by dragging the mouse, it should be pretty intuitive. The player itself also maintains the proper aspect ratio of the source video no matter what dimensions its in.

If you could be more specific and clear about the issue I’d be happy to help. :slight_smile:

I’d like the player to keep all of the video within the player window, at a specific aspect ratio, regardless of what else is on the screen. As it is, the more widgets I put on the screen, the less of the video I can actually see and I can never see the complete video without scrolling up and down or across the screen. Forgive my ignorance, I do not know video but am trying to learn.

Hi, thanks for responding, your second post is much more clear. I’ve changed the topic category to help/how to.

I see what you mean now, that the player has to resize itself depending on the setup being used for the program. Here are some screenshots I have:


You can clearly see how the player has been forced to scale down due to the recent tab taking space above it. I think this is what you’re trying to describe. Shotcut does this intentionally though, because the program has to make room where it can. The program also must preserve the dimensions of the original video. However I think where you’re confused is about the meaning of aspect ratio. Aspect ratio is fixed, it is the relative width of a video in relation to its height (16:9, 4:3, etc). More information here.

As a solution though, you can choose the “restore default layout” option, leaving the bare-bones player free from any widgets, and then you can add them one by one from the “view” menu. It looks like this:

If you have any questions or this isn’t what you’re describing, sending some screenshots of your Shotcut would help :slight_smile:

I’m pretty sure we’re on the same page now. The problem is that the image is not scaling down when I add widgets, it just adds widgets covering more of the video. I notice you are looking at the source material and not in the timeline. Could this be the problem? I am looking at video in the timeline.

The player follows the same scaling no matter if you’re in the source OR timeline, it doesn’t make a difference. At this point the only way I can help you is if you have screenshots. Sometimes there is a bug with OpenGL if you’re using Windows and the only way I can tell that is from looking at a screenshot. :confused:

Hard to see but this is “full screen”…but still has scroll areas

Image deleted because I am a new user.

Now, you see that more of the screen is covered with the playlist widget.

Image deleted because I am a new user.

…and now even more is covered with the audio peak widget.

Hi, you should zoom out with the tool highlighted by the red box.

1 Like

That’s what I was looking for! Thanks, Luis!