How to keep text size static?

Hi, I’ve added subtitles to my video. Have kept the text box size fixed but since the number of characters varies, font size isn’t kept constant. Have tried looking at some youtube tutorials but couldn’t find solution to fix an already messed-up situation i.e. I need a fix that will resize existing text to uniform font size. Thanks.

Tick the Use font size box (red arrow) then click the Font button (green arrow) to choose a new font and edit font size.

3 Likes

Can I apply that to all text boxes?

Yes

i.e. there’s a way to automatically apply font settings to all text boxes? If that’s the case, would you mind telling me how?

Once you formatted the text, use the copy icon and paste it in the filter box for all other text boxes

1 Like

I already have different text in the other text boxes, which I don’t want to change. I’m trying to only apply format changes on all text boxes without changing the content

Hi @tuber, copy the filters from text 1 clip and paste to text 2 clip. You’ll end up with all the filters copied, including the text from clip 1. But BOTH text (simple) filters will now be on text clip 2. So then delete text filter 1 (filter pane, using the minus icon) and you’re done.

1 Like

Makes sense, thanks. I will have to do this for each existing text box, right?

@tuber, yes, but once the filters are copied to the clipboard, no need to keep copying. Just select a text clip, click “paste filters”, then delete (or hide (uncheck)) text filter 1. Just two mouse clicks.

1 Like

Got it. That’s helpful, thanks!

Could you please let me know what I’m doing wrong? Basically trying to make Text 2 (large) look like Text 1 (small). I copied filter from text 1 to text 2, then hid text 1 as you suggested.
Result is that the size and position of text box have been copied, but text itself remains same as before (large). You can see that the text is now slightly out of the text box.

The filter settings you are showing, will not show on the preview because you have it unchecked. When you uncheck a filter, you have it deactivated, thus the filter effect is removed from preview.

The text you have in preview, that you have circled, is from a different filter.

1 Like

You’re right. Sorry, I should’ve shown this screen, in which the original text is checked. My question is then is there a way to keep the copied filter without keeping the copied text (this is what I understood I should do from the previous comment).

No. Also, regarding the text size, you need to keep in mind that the Size parameter will also be a limiting factor affecting the text size. If you change the text in the screenshot you show to add more words, it does not wrap and instead the text size eventually shrinks to fit all of the text within the rectangle (Size). Your options are:

  1. Make the Size bigger (not font size) and use the Position, Horizontal fit, and Vertical fit to control the placement.
  2. Use Text:Rich, which does not auto-adjust the text size and provides wrapping.
1 Like

Thanks will manually adjust the size.