How to fade out an image?


#1

Hello,

I applied a video filter ‘fade out’ to an image on a seperate video track. I can’t figure out how to make it work, because the filter doesn’t do anything! Is there a seperate ‘image’ filter tab I need to use? I only see a video and audio tab.

I just want to know how I can fade out an image.

Thanks.


#2

https://streamable.com/mvkbs

2018-02-12_073821


#3

Thanks for your reply.

I tried it, but it still doesn’t do anything. I applied the video filter to a .png image which has transparent parts. I applied the video filter fade out and checked the box. Still nothing.

OK. Quick addition; I noticed that another track where I also had a .png with transparency in the same project had the same filter to it. Without that box ticked. And that image DOES fade out. I think it’s a bug or something.

I have a .png file that I added to the ending of the track. It starts showing/playing towards the end of the track, about 5 seconds before the end of the whole video. Now when I stretch that image, all the way from the beginning to the end of the track, the fade out will work as expected. But as soon as I shorten the duration of that .png image in comparison with the video track, the filter doesn’t work anymore.

Perhaps you can reproduce.

Thanks.


#4

Works fine here as described.


#5

Hi,

Sorry but it doesn’t work for me. Even when I try dragging in from the corner as shown in your video.

Try this:

Add a video to a track for example for the duration of a minute.
Then add an image on a new track, add the image in halfway in comparison with the video track and let it end perfectly to the end of the video.

Then try to apply the fade out filter to the image. I swear, when you do that, the filter won’t work.

I just noticed while trying something while typing this, that it worked. But that was only one time, I don’t know what I did. I saw two tracks selected in gray, on the left side. No part of any track was selected. I played it and it worked.

As soon as I went back to tooling around it doesn’t work anymore. It’s still not working in the preview or the exported video. I wonder what is going on?

I’m clueless!

Thanks.


#6

Done, and works fine for me here.
You haven’t mentioned which OS you are using and which version of Shotcut?
I use Windows 10 Pro 64bit and the most recent Shotcut 18.01.02


#7

Hey,

I’m using Shotcut 64bit, 18.01.02 as well. Running on Windows 8.1 Pro 64 bit.

I can try running it on another computer of mine. See if that makes a difference.

Thanks.


#8

Just reinstall the program over and retry.


#9

Seems flaky. With GPU disabled, it seems to work and sometimes gets stuck while fading out at about 50% of opacity at about 50% of the time, then jumpcuts when the top clip reaches the end. Can be fixed by removing and re-adding the filter.

tested both with png and jpg.

Side-note: creating a project in non-GPU mode, then switching to GPU, opening it again, then switching to non-GPU makes me unable to open the project (shotcut crashes when I do). 18.01.02 win10 64b


#10

I’m having the same problem with Shotcut 18.03.06.


#11

Try adding a Rotate filter to the image that isn’t fading out.