How to enable GPU Rendering?

Hello everyone^^,

i know there are some similar questions about that topic, but they didn´t help…

i want to render a video of my gameplay. for Youtube but the rendering process will take 8 hours for a 30 minutes video…

My CPU (Intel i5-4430) is going crazy at the process (90% utilization) and my GPU is chilling (2% utilization). How could i enable to render over the GPU? Are there some hidden function?

i started Shotcut already in OpenGL but i don´t find the “GPU processing” setting.

Thanks a lot. <3

What did you do so far?
If you searched before, you probably have already enabled “Use hardware encoder”.
There are no hidden function and everything is accessible in the export panel under Advanced.
It could depend on the graphics card which might not be compatible. There is a topic in which this is discussed ("Use Hardware Encoder" on Dell Inspiron Laptop). There is also further information in enabling hardware encoding.
You also should check the log which you can open by right-clicking the job in the jobs panel and pressing on “View log”. There should be something about initialising nvenc or amf.
GPU%20initialisation

GPU processing is a very error prone feature which is disabled because of many complaints. That is why it is difficult to enable it and not just a simple setting.
Either way, this has nothing to do with the rendering process so turning it on will not lead to lower rendering times.

Thanks for your reply,

so i looked at the “Use Hardware Encoder” and did everything, but nothing worked.
It seems my GPU isn´t compatible (Nvidida Geforce GTX 660 OC).

Sad for me :frowning:

I think it should be for H.264 according to this:

You have to click the green GeForce / TITAN button to expand the table. You should try again and look in the job’s log as @samth has done.

Hey,

i´m going to check that today and give you the resault for H.264 encoding.^^

But what do you mean exactly with that?
If you want i could do a short video of my system and settings in shotcut.

In the table @shotcut linked there is a button called “GeForce/TITAN” and pressing it reveals that the GTX 660 is supported (only for H.264).
Export a project and open the jobs panel by pressing Ctrl+0. Follow my instructions to check the log.

ok i saw the table now, thanks!

I will do that after work and give feedback this evening. :slight_smile:

Sorry for the late reply…

[Debug ] ShotcutSettings::log language “de_DE”
[Debug ] ShotcutSettings::log deinterlacer “onefield”
[Debug ] ShotcutSettings::log external monitor “”
[Debug ] ShotcutSettings::log GPU processing false
[Debug ] ShotcutSettings::log interpolation “bilinear”
[Debug ] ShotcutSettings::log video mode “”
[Debug ] ShotcutSettings::log realtime true
[Debug ] ShotcutSettings::log audio channels 2
[Debug ] ShotcutSettings::log display method 15

So there are the log files…

Da Du augenscheinlich Deutsch verstehst, antworte ich Dir lieber auf Deutsch.
Du hast das Anwendungsprotokoll geöffnet, “jobs panel” steht jedoch für das Aufträge-Panel und wenn Du dort auf das exportierte Video mit der rechten Maustaste drückst, kannst Du “Protokoll anzeigen” auswählen. Dieses Protokoll wird Dir die Zeilen anzeigen, die im Screenshot zuvor zu sehen sind. (Und öffnen kannst Du das Aufträge-Panel eben mit Strg+0.)

You opened the “Application log” but the aforementioned “View log” is accessible by right-clicking on the exported video in the jobs panel. This log will provide you with the lines similar to the previous screenshot I posted.

Da hat mich wohl das Anwendungsprotokoll verraten.^^

Dachte ich mir schon, dass du dieses meinst war mir aber nicht 100% sicher, ich werde heute Abend nochmal reinschauen.
Sorry das ich aktuell nur sehr sporadisch Antworte, leider beruflich sehr viel unterwegs, bin aber sehr froh und dankbar, dass du mir hilfst.

Wie schon gesagt, ich werde heute Abend nochmal in das Protokoll beim Exportieren reinschauen und diese vergleichen und hier posten.

Danke! :slight_smile: