How to disable non parallel processing?

Hi!
By default shotcut works like this: First it tries to export video in parallel mode and if it fails it exports it in non parallel mode.

You can disable/enable parallel processing in advanced export parameters pannel.

Can you disable non-parallel processing? I mean that if shotcut fails in parallel mode, it doesn’t try to export in non-parallel mode.

That behavior can not be disabled.

Perhaps it would be nice to add this as suggested feature then? If you have longer video (or not so long but having many “bricks” which makes it complicated) then going into non-parallel processing means much much much longer export. Sometimes it’s better to search for reason of problems than to go into non-parallel processing…