How to blur part of the picture?


#1

Hello,

I need to blur part of the picture in a video, such as someone’s face.

Is this still the best way to do it?

Thank you.


#2

You can also use mosaic now


#3

When I try to do the second video, my v1 track doesn’t let me turn on and off the compositing button. Is there something simple I’m missing? If I add a second video track, I get the button to work, but when I apply a filter, nothing changes in the video.

Any ideas?


#4

I answered my own question, but not sure why it works like this. I had to downgrade to the version referenced in the video, it didn’t work on the newest version


#5

This video track configuration and filter setup works with the latest Shotcut version 18.06.02.
V1 has no filters applied to it.

Video with the mask and mosaic filters using keyframes

https://streamable.com/jajc8


#6

It looks like yours is doing the same thing mine did, V1 doesn’t let you turn on or off composition, but it looks like you’ve turned on both mosaic and mask on the same track. Is that how you need to do it in 18.06.02? The instructions in the video were for them to be in seperate tracks


#7

This is how it works in 18.06.02.

You can put the Mosaic or Blur filter on V1 but then you have to change the Mask filter’s operation mode from write on clear to subtract for it to work properly.


#10

I don’t understand how you do it. Is it possible with only 2 video tracks? Here’s what I do but I can’t get the result I want.
I add a track and drag the video in.
Add a new track and put a copy of the video in.
Then on V2 I add a mask in substract but when I click on compositing nothing happens I don’t see any difference and that in any of the mask mode possible even if I “hide” the V1. I can blur it but not put a mask except if I remove the V1.


#11

Here’s a short video demonstrating how to use the mosaic and mask filters to blur part of an image.

https://streamable.com/67lwe


Can I upload a Shotcut project for others to inpsect?
#12

Oh thx. For a unknown reason if I do it in precisely this order it works but not if I add a track, put the video in it, add a new track and then copy the video and add the blur and mask >.<


#13

I have a “How To” video also if it helps:

Edit: So i post this to HELP and suddenly get a thumbs down on the video?!?!?