How do I solve [YUV color matrix] problem?


#1

Hi
I’ve been editing some videos that I think were already processed once (taken 4 yrs ago)
into the current format of MP4 with 59.94fps, 720x480 res, 2k bitrate and the length between 1:44:34 and 2hr 20min something.
I cut it down to around 35~50 min long and tried to export with below average quality setting in h.264 main or WMV or whatever mp4 format.
It stayed @ 0% for some minutes and then started very slowly with est time of about 3hr each.

I checked the active log and found out it had a lot of these lines unlike other videos which started like in few seconds after I clicked export file (most were similar in playtime and with the same export formats, I’m standardizing these vids). But some of the recently recorded videos also has the problem while others don’t.
They are in MTS and split about 2GB in size for about 12min(I know this recorder sux but I don’t have alternative for now)

The line is something like this:
[swscaler @ 000000001823ed80] YUV color matrix differs for YUV->YUV, using intermediate RGB to convert

there are hundreds of these lines with slight difference in numbers and characters after @ b4 it actually started the work. And for example the est time is like 2hr 30min when it’s 5% done. The okay ones above took like 30min max.

Is there any way to solve this problem and I might wanna know what causes this and how to somehow prevent it if any.
I googled it b4 I wrote this but didn’t get much. And some r also in the forum I guess? that didn’t get any replies

Thank you.


#2

Those messages are not “problems”. They are just a way for the internal processing engine to tell developers that it performed a conversion.

The 3 hour export time is not unexpected.

As long as your export looks good, don’t worry about it.


#3

Those lines means it is converting the colorspace, most likely from ITU-R BT.601, which is what your SD source file is using, to ITU-R BT.709 for HD, which is probably what your project is set. If you want things to go faster change your Settings > Video Mode to SD NTSC or DVD Widescreen NTSC depending on the aspect ratio you desire. Not only does the colorspace conversion add overhead to make things slower, but moreover upscaling and the encoding of a higher resolution is going to make the biggest impact. If you change the Video Mode of an existing project, you will need to review the entire project for correctness because while some things convert fine, not everything.


#4

Thank you for the answer!
I’m kinda noob on these things so I thought it was a problem that somehow slowed things down.
But the actual “problem” is I can’t afford 3 hrs for every file, or like most of them.
Or is there a way that I somehow change the colorspace of my files beforehand so that shotcut doesn’t need to do it while enconding?


#5

Oh. I thought it was just for playback during editing.
Does that mean the video mode have anything to do with the quality of exports, or not?
To be fair, this current works don’t really require the best quality so it’s not the priority yet.
I’ll try what you suggested and report if things don’t go well.

Much appreciated :slight_smile: