How do I remove letterboxing from a video?


#1

Using Shotcut, how do I remove letterboxing (those black frames / bars at the bottom and top of a video) from a video?
Thanks.


#2

Letterboxing is a result of formatting a video with one aspect ratio to suit another while maintaining the original quality or proportions of the film. You can change the aspect ratio of a video in the properties tab. Common aspect ratios are 4:3, 16:9, and 16:10. However be warned that this causes distortion to the clip.


#3

Thanks, Lauren.
The video I’m dealing with already came with the borders coded into the video (I’m assuming it’s a 16:9 movie formatted so that it can play on a 4:3 TV set).
I don’t want distortion.
Is there a way to crop the borders away from the video with Shotcut? Thanks.


#4

From a fresh start, before opening the clip, in Settings > Video Mode choose something other than Automatic that is HD or maybe Non-Broadcast > DVD Widescreen. Then, open your clip. Go to Filters and add the Crop video filter. Adjust the top and bottom values so they are roughly the same and remove your black bars.


Black bars being added back in
#5

Excellent, that did the trick. Black-bars-be-gone!
Thank you.


#6

Hi I had this issue to but with side bars - I found your solution and tried it but couldn’t get it to work - many hours of tearing the proverbial hair out and then I discovered why.

I don’t know if you version of Shot Cut is different to mine - I am running 18.03.02.

From a fresh start, before opening the clip, Coose Settings->Video Mode from the menu and select an HD/Non broadcast mode.
Open your clip.
Go to Filters and add the Crop video filter.
Adjust the top and bottom values so they are roughly the same and remove your black bars.
( in my case left and right )
Drag video to track.
** If I tried to export at this point the resultant file would still have black bars **
If you however select settings video mode-automatic - and then drag it to the track it will now export without black bars.

But thank you for the previous parts because without them I never would have found a solution.


#7

I did not reproduce a problem using your steps.

Drag video to track.

Did you know that it is not necessary to use the Timeline to Export?


#8

That’s odd I can reproduce it every single time, maybe I should use Shadowplay to make a video of what happens and upload it; maybe I am doing something different or wrong and that is why it’s happening this way for me.

BTW I’m not just cropping black bars I am also doing a little cutting and joining so moving to the timeline in my case is required.


#9

I, too, have this issue. The source video has letterbox padding, anamorphic, and is stored at the wrong DAR. I want to remove the padding and fix the display aspect ratio. I also don’t want to degrade quality by re-scaling the video. I do want to cut and use filters, but otherwise, encode it at its original resolution.

I’m struggling with the relationship between the source aspect ratio, video mode, cropping, and export resolution and aspect ratio. I’ve tried a couple of things, but ended up adding more padding and made the aspect ratio distortion worse.

Source: 720 x 480. 60px padding top and bottom, so the video is 720 x 360. Stored at 1:1 DAR, but actual DAR 8:9.
Desired outcome: 720 x 360 encoded with 8:9 DAR (playback at 640 x 360).


#10

Settings > Video Mode > Custom > Add… Then, add a Crop filter to remove the black bars. In case the displayed aspect ratio is incorrect and you need to override it, you can use Size and Position with Size Mode set to Distort.


#11

This did the trick! Thank you! And just a note - I took a chance and edited the Video Mode settings in an existing project (instead of starting fresh) and it did not distort my video. :slight_smile: