Hi, how can I change transition of text?

I want to change the transition of text so it is not classic fade in, fade away. I looked on youtube on how to do this but was met with an unpleasant shocking surprise.

The tutorial I was looking on had easily accessible customization at their hand but mine was not to be seen.

Can someone help me understand the problem? Is it because versions of shotcut differ? Much help appreciated.

I take it the screenshot is from the tutorial, since there is obviously an option to change the type of transition (default is “Dissolve”). What version of Shotcut are you using? A screenshot showing the properties of your own transition would be useful.

I am using 22.06.23. Please help, I am not sure what is happening.

That version definitely has a variety of transitions.

Just select (click on) the transition and it then on “Properties”. You should be able to change the type of transition by clicking on the selection (see below). If no, post a screenshot so we can see what is happening.

I have only this small windows, hoped I did everything correctly.


You create a transition by dragging one clip (your text clip) over another, e.g. your video. The overlap is the transition. You need to select this overlap to change the type of transition, dissolve, barn-doors etc…

When you provide a snapshot please create it of the whole Shotcut window. Just looking at a small portion doesn’t really give an idea of what you are doing wrong.

I am not sure where are you going at. I have text on another video track above my image, as it should be.

Then it is not a transition. A transition is where 2 clips on the same track overlap, which is what you showed in your original screenshot. The frist clip transitions into the second clip and this is where you can control the type of transition to dissolve, barn-doors etc.

first clip has the video track with subtitles above video track with image, buddy.

there is no point changing transition would not work if subtitles are above video track with image, as you can do transition already but with only deafult appearance option. Tell me what I understand wrong and how to do it properly.

As you can see. In the track above the video the guy has the text clip and another transparent clip next to it. He drags the text clip to cover part of the transparent clip, thus creating a transition. He then selects (left-clicks) this transition and then changes the type of transition to Dissolve or Barn-doors etc…

There are many ways to accomplish transitions on Shotcut. The options you are showing in your screenshot only appears when you do what is considered a “default transition.”

A default transition is when you drag one clip over another clip on the same track, creating an overlap. The overlap is indicated by a box with an “X” in it.


If you select the overlap box, you are then shown the option to change transition type

Only through “default transitions” will you see these options.

thanks m8, will look into that tommorow

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.