Hevc_nvenc - not available (not work)

Version 23.05.07
Linux Mint 21.1
Mesa 23.2
NVidia Driver version 530.41.03

The hevc_nvenc hardware encoder is not available, which was available and worked properly in version 22.12.21
The output of the ffmpeg -encoders command tells me that ffmpeg supports this encoder.
When trying to force activate this encoder, the render starts with an error. Below is the LOG of the error.

Gtk-Message: 19:56:44.780: Failed to load module “xapp-gtk3-module”

[hevc_nvenc @ 0x7f6f28002080] Loaded Nvenc version 12.1
[hevc_nvenc @ 0x7f6f28002080] Nvenc initialized successfully
[hevc_nvenc @ 0x7f6f28002080] 1 CUDA capable devices found
[hevc_nvenc @ 0x7f6f28002080] [ GPU #0 - < NVIDIA GeForce GTX 1050 Ti > has Compute SM 6.1 ]
[hevc_nvenc @ 0x7f6f28002080] B frames as references are not supported
[hevc_nvenc @ 0x7f6f28002080] No capable devices found
Failed with exit code 11
Failed with exit code 11


Weird. It works for me on Windows, and you did leave B frames at 0?

I didn’t change the default values that went in “HEVC Main Profile”, the default is 0, as you can see in the screenshot from my first post.
This is for the flatpak version.
I just downloaded the appimage version, and for some unknown reason, the hevc_vaapi encoder does not work in it.
The windows version works with all four encoders, but my main video editing system is linux, I really want all encoders to work in it, including hevc_nvenc, which I use very often.

I do not reproduce this on my only Linux system that has NVIDIA running Ubuntu 20.04 with driver version 525.105.17. Flatpak, Snap, and AppImage all worked for me. I will not be working on this. You can hope that some change in components will align like the stars to start working again. (VAAPI on Linux with portable binaries is always even more of a gamble due to higher version sensitivity between components.)

This topic was automatically closed after 90 days. New replies are no longer allowed.