HELP..Video stripped off and only audio exported?

I’m new to Shotcut and have downloaded the latest version 19.12.31. I have loaded a video with integrated audio into the timeline and simply clipped its length. I have then exported the project in YouTube format. All seems normal with the export process, but when I play the resulting MP4 file all that is present is the audio part and the video part has been stripped off!?

This is driving me crazy…Is there a setting in shotcut that I have missed?

Thanks for your help

Not sure what you mean by integrated audio.

When you go do properties of the clip, what do you see?
1 channel or multiple?
shotcut_2020-02-04_09-24-56
Shotcut can only do one 1 audio track (in a source file) at a time on one track.

Make sure you’re not muted.
shotcut_2020-02-04_09-28-40

If you have stereo (2ch) audio track(s) is does your audio setting reflect the same?
2020-02-04_09-30-43

Thanks for responding.

Only see 1 channel.2720x1520 h264

By integrated audio I mean the original video was recorded with sound and in the Timeline the audio wave form shows below the video in the same track as expected

It’s under the Audio Tab
Click the down arrow to see all of the channels.
2020-02-04_09-55-33

image
Under codec in your export options there’s a “disable video” function make sure you didn’t check it by accident(I’ve used it on purpose to edit audio after i’m done cutting in audacity and then bring my audio back in)

Thanks.

Its exactly like your screen shot

Thanks for the tip, but I’ve checked and “disable video” is NOT ticked…

Its all very strange :frowning:

Exactly like what screenshot?
Do you have more than one audio track in your video file? Yes/No?

Instead of this back and forth getting information to help you, I think reading this may help out the situation more. This way you can provide all of the information at once.

Thank you for your efforts and I share your frustration…believe me! I had googled and checked all the FAQs and forum before raising the issue…

I have solved the problem by employing the tried and tested method; ie.uninstalling the Shotcut app and downloading a new copy…everything works perfectly now as it should!! :slight_smile:

I thought I had fully described the issue originally “All seems normal with the export process, but when I play the resulting MP4 file all that is present is the audio part and the video part has been stripped off!?” Maybe you were overthinking the problem? Obviously a software glitch somewhere…

Thanks again…case closed

Having exactly the same issue, but even uninstalling isn’t working :frowning:

It’s just for this one project file though. Everything else is fine. I’m baffled and very, very annoyed.