Help! Shotcut won't switch audio playback devices!

What is your operating system?
I am running Windows 10 as my OS.

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
I am currently running the latest version of 64-bit Shotcut.

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)
The problem can be replicated for me whenever I unplug my audio jack, and then re-plugging it, and then having Shotcut fail to consistently switch between the two audio playback devices.

Extra details
So, when I’m using Shotcut, sometimes, when I plug my headphones in, Shotcut won’t swtich to the headphones for audio playback, and will instead keep using the speakers for playback.
Even when I uninstall or disable the speakers in Device Manager, Shotcut will still use the speakers for playback instead of swtiching to my heaphones.

I have tried restarting the program, and even then, the results are fairly inconsistent. I have also tried closing it via Task Manager, and it did not work.

In the meantime however, I would like to know if there is a way to switch the audio playback device in the program, or maybe even using a third-party app to force it to switch to using my headphones as the playback device.

Unless you’re using a 3rd party audio profile like VB Audio, all audio will be on system default. On my computer it’s Realtek.

Check Windows 10 Audio settings with Shotcut open to see what your default is. Although from what you’re describing sounds like a dirty/faulty audio jack on the computer itself. Most desktops will have a headphone port in the back that match the front headphone port.

Click here for Windows 10 Audio settings.

Top “Default” is output. Bottom “Default” is input (Mic).
Because I’m using Realtek for my audio driver, leaving them at Default, lets Realtek handle the distribution.

Since I use Shotcut, it picks up the audio device settings at startup. After that, no changes to audio devices take effect.
I assumed this was the behavior by design (since at W10 I don’t know a way to change the audio engine or device within Shotcut).
On Linux, there is an option to use the audio Jack engine instead of Alsa or PulseAudio, still after the choice, you have to reboot for the configuration to take effect.
So, I choose first the audio device (headphones, line out, etc) before starting Shotcut.

This is a known bug. We use a library for audio output, and when we upgraded it to fix this bug, which it did, then a minority of others reported the audio is heavily distorted with scratches or crackling. So, we had to downgrade that library. This happened twice. I suppose this will never be fixed until code is rewritten to not use that library and then likely there will be other bugs.

This always works for me. If it did not for you, then I suspect there is a Windows audio setting that is set incorrectly (Shotcut set not using default device).

Hey, thanks for replying!
The weird thing is that my headphones also use Realtek, more specifically, Realtek High Definition Audio (SST).
In light of this, any second opinions?

Hey, thanks for replying!
Maybe this statement was just a false memory, so I have to double-check this statement, and will edit the question if it not true.
For the meantime, just ignore it.

Are we considered accomplices if we help RickRoll fix an audio problem? Be careful with any links you click from him. :rofl:

I use the driver directly from Realtek’s website, instead of the one supplied by my motherboard manufacturer (ASUS).

I do suggest you also acquire the standard audio driver from your computer/motherboard manufacturer. You can find the driver in their support websites.

Unless you have a specialty audio card installed, you’re using a tiny Realtek chip that’s soldered on the motherboard.

I didn’t know about a bug with Shotcut’s audio until @shotcut mentioned it. I have never experienced any audio issues with Shotcut.

The only reason why I use Realtek’s driver is because I had issues with GeForce Experience giving me audio lag when recording with OBS.

Hope this helps. If not, I hope it’s something really simple and easy to do.

Hello everyone, and thanks for responding! You have all been very helpful.
However, some else on a Reddit thread that I started alongside this one has posted a solution.
A user that responded to my post has suggested going into settings and switching the audio channels.
That has worked for me, but once again, thank you to everybody who has responded.


This topic was automatically closed after 90 days. New replies are no longer allowed.

Fixed for next version 23.07