Help please. Missing tracks when exporting audio

I am using Shotcut to edit my podcasts - for both audio only-version and a video version for YouTube.
I have two video tracks (with audio) from the two speakers and two audio tracks, one being intro music and the other a sound effect.
Exporting the video went fine.
However, when I export the audio version, the file misses two of the tracks: one of the speakers and the sound effect, so one video track and one audio track.
I’ve tried WAV and mp3, both have the same result. Nothing is muted, it all plays fine within shortcut and the video export also has all audio tracks intact.
I have been searching for two days and I can’t find the problem, nor an explanation online.
Granted, I am a newbie, so please forgive me if there is an obvious answer to this problem.
I appreciate any help!

What is your Shotcut version? Go to Help > About Shotcu to find out. Is your version 32-bit?

Also can you post a picture of your project’s timeline?

What export preset are you using for the audio export? It sounds like tracks might be getting dropped from a channel layout issue. Are there any panning filters or channel-copy filters being used on the tracks?

Version 20.11.28
Where do I find out if it’s 32-bit? Can you tell by the version?

I’m not well versed yet so I didn’t understand all of the questions. Also, my Shortcut is in German, as am I, so I might have some language barriers here and there aswell. I’ll try to respond as best I can.
Presets… Not sure what those are. Is it what I chose for exporting? So like for the video I used “YouTube” and for the audio I have tried WAV and mp3. ?
Channel layout issue?
panning filters or channel-copy filters?
Sorry, I don’t know what those terms mean. :weary:
Does the picture I posted as response to DRM offer any answers to your questions?

Update: I made a new project, imported all the files (2x mov, 1x mp3 and 1x wav and an mp4 that I forgot to mention earlier, it’s the endcard (for YouTube)) and exported a wav audio as is, without any editing, just to see. All audio can be heard.
So I conclude that the problem is something that I did while editing.
I could start over and do it all again, but I would like to figure out what I did to cause the problem so I don’t do it again.
Any ideas?
For what I did/which filters I used: I have several cuts in the files, fade in and out on all audios, some parts muted, split screen (so size and position filter) on the videos, dB adaptations and a layover on one of the videos and the endcard.

Update update
After I closed the testing project and was about to go back into the original project with the issue, I noticed that there was now a project in the list with the same title and the addition “repaired”. I opened it, it’s all the same as the original one, did a wav export, and voilá, it works!!! :)))
I have no idea what happende there, and would still like to know for future reference, so I am grateful if anyone has any ideas towards, but in the meantime I am happy that it works now!

This topic was automatically closed after 90 days. New replies are no longer allowed.