HELP! I can't export frame

I want to export a frame and I can’t. When I right-click on the file, there is no export frame. And when I click on it, export frame does not show up. I also tried to right click export and see if it under that. I don’t know what to do. Please help!!!

File>Export Frame ?


i dont have that

Then you don’t have Shotcut.
Where did you download the installer from?

@TheSaltyWoodchip, can you post a screenshot, and/or walk us step-by-step through what you’re doing to get to a file menu without an “Export Frame” option? (i.e. “open shotcut, open MLT file, left-click in the Timeline, left-click on the File Menu…” etc)

This is what it shows. I got shotcut from a separate website that made it easier. I think it might be an older version. When I click file this shows up.

I got it from some other website

I just want to say thank you to all you guys who helped. I removed the shotcut I have and downloaded it from shotcut and it worked. Thanks mainly to Steve_Ledger. But also to you guys for helping