Hebrew Translation

Neil thank you.
Do I just copy that overlay into the text box? How do I use the overlay??

How do I use it to also change whatever I write? (different clips)

I am really not understanding how to do it. Very foreign to me this programming language :blush:

Just seen your question - been out all day and nearly midnight here in Cyprus. There are several ways of using the Overlay HTML filter. Can I check how you want to use it?

Do you have a video and at various points within that one video you want to show some text on the screen (in the middle, at the top or at the bottom) for a short time.

Do you want to blank out the video when the text shows or show the text as subtitles?

Do you want something simple or something more complicated like animated text?

The answers to these will give me a better idea of how to respond.

I uploaded the file I am working on the other feed. I will add it here again…

I just want to have whatever I wrote in English to be also in Hebrew and not cover the dog in the video and picture…

Animated (ie. moving) text would be nice for effects but at this point my main concern is to get the Hebrew to show up.

I manage to get it in the text box but it does not show up in the viewer. Neil managed to get Hebrew to show up in it on his comuter and others have as well, I am concerned that it is something with the way my Surface Pro sees shotcut. I have a Hebrew keyboard and can write Hebrew in all my other programs. I cannot copy and paste from Word for now coz I just reset my computer and lost my Office program in the process until I can get to my discs back in the States this winter…
Thank you for any help.
Allis Chiro Rx.mlt (20.0 KB)

Gil, or anyone,
I don’t know what is the video lingo in other languages but “Hebrew” videographers uses the common english lingo. So I see no benefit at all in translating the menus. Let along that all the more advanced NLE do not have hebrew interface. So if one used to impractical hebrew lingo it will be much hard for him to move to other NLE.
my 2cents.

25 years ago, I thought a young girl who had no english at all how to use media composer on MAC. She was great in the editing parts of the program, once she needed other non related things a technician helped her.

Hi Neil,
I just decided to give up and export the video as is and the Hebrew showed up in the exported video!!
I had tried the HTML overlay and it still did not show up on the viewer…
So thank you all for your help!
Just guess I have to trust the Hebrew is there when I edit videos and know it will be there when I render/export.
If anyone has a solution why on my computer the Hebrew does not show up in the project viewer I would appreciate that fixed!


How interesting, I never got round to checking out the exported file. Like you I couldn’t get it to show in the preview pane when I used the TEXT filter, only when I used the Overlay HTML filter, so I just assumed it wouldn’t show on the exported video.

The Overlay HTML filter is useful to produce things like animated titles, screen credits and subtitles. Basically you put the HTML into a file (e.g. “title.html”) and pass this to the Overlay HTML filter in Shotcut. HTML and CSS are a great way of quickly producing semi-professional animation effects.

There are several posts on this forum showing how to get these effects and I have put together a framework to help users to get the most out of this filter and put it up, with examples, on my website at www.elusien.co.uk/shotcut. See the following:

By the way, I too am using Shotcut on a Surface Pro and do not see any problems with it.

P.S. If you want to process word docs before you get to your disks in the USA try LibreOffice (https://www.libreoffice.org/). I use it all the time as I don’t have MS Office on any of my Windows systems.

Best wishes in using Shotcut.

I have no problem, so far, exporting Hebrew

This is the VLC screen.

I was thinking the Surface Pro was a laptop, which in fact it’s a tablet. Which version of Windows do you have? What are your tablet specifications? (Windows Key, System Information)

  • OS Name
  • Version
  • System Type
  • Processor
  • Installed Physical Memory
  • Available Physical Memory

I can tell you it is a Surface Pro 4, with Windows 10 installed from factory.
It has the keyboard attached and the only thing I did not factory default was added the Hebrew keyboard in languages.
Available Physical memory in “This PC” is 158GB of 237GB

I am not sure how to check what processor or system type (unless that is Windows 10)

OK so:

Device Name: DESKTOP-E3EKR6G
Processor: Intel core IS-6300CPU @2.40GHZ - 2.50GHZ
Installed RAM: 8GB
System Type: 64-bit operating system, x64-based processor
Windows system:
Windows 10 Pro version 1803
Hope this can shed some light onto the problem
Thank you

@shotcut, @brian, @mqldvm,

Monique’s problem is not related to the fact she is using a Surface Pro. I have used a similar-spec Surface Pro for much more complicated videos.

The problem is a BUG/DEFICIENCY IN SHOTCUT - it cannot display in the preview pane a script that is written Right to Left, such as Hebrew, Urdu and Arabic,

I just used the text filter writing in the following scripts:

  • Arabic (R to L)
  • Armenian (L to R)
  • Cyrillic (L to R)
  • Hebrew (R to L)
  • Kanji (L to R)
  • Korean (L to R)
  • Tibetan (L to R)
  • Urdu (R to L)

All of them were perfect on the exported video, but the three Right to Left scripts (Arabic, Hebrew and Urdu) would not appear in the preview panel, the characters just showed as spaces. (It does show correctly in the box you type in the filter)

A العَرَبِيَّة Arabic
U چھوٹی يے Urdu
K 片仮名 Kanji
H עִבְרִית Hebrew
A Հայոց գրեր Armenian
K 한글 Korean
T ཁམས་ Tibetan
C русский язык Cyrillic

Perhaps one of the developers could look into this to see if there is a quick fix.

There will likely be no quick fix for this unless someone contributes the patch.

Maybe I’m not quite understanding the bug.

Shotcut 18.09.16 (64-bit)
Windows 10 (64-bit)
i7-7700k, 32gb ram

The problem is shown here (I’ve even uninstalled Shotcut then re-installed it ticking the box to "remove Shotcut parameters from the registry):

Shotcut version 18.09.16

|OS Name|Microsoft Windows 10 Pro|
|Version|10.0.17134 Build 17134|
|OS Manufacturer|Microsoft Corporation|
|System Model|Surface Pro 4|
|System Type|x64-based PC|
|System SKU|Surface_Pro_4|
|Processor|Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2496 Mhz, 2 Core(s), 4 Logical Processor(s)|
|BIOS Version/Date|Microsoft Corporation 108.1926.769, 06/12/2017|
|SMBIOS Version|3.1|
|Embedded Controller Version|255.255|
|Hardware Abstraction Layer|Version = "10.0.17134.285"|
|Installed Physical Memory (RAM)|4.00 GB|
|Total Physical Memory|3.93 GB|
|Available Physical Memory|695 MB|
|Total Virtual Memory|13.9 GB|
|Available Virtual Memory|5.05 GB|
|Page File Space|10.0 GB|

How can you claim the problem is not related to using a Surface Pro when you tested on a Surface Pro?!

I had also tested it on an Acer Revo RL80, with the same result (R to L script doesn’t work in the preview pane), but at the moment that system doesn’t have an internet connection so I couldn’t cut-and-paste the relevant screenshot and sysinfo into the reply.

Shotcut 18.10.01 Windows 10 Pro HP Prodesk PC.

I installed the Persian language pack (R to L script) and typed Persian into the text box. Also typed English into a second text box. Both display in the preview/source player pane and export perfectly well.

Persian.mlt (4.8 KB)

Persian.zip (15.7 KB)

I tested it as well using Hebrew and was unable to reproduce it. I did not copy and paste text from anywhere. I switched the Windows keyboard input mode to Hebrew and typed some with the keys. I even saved a project and reloaded it. Strange

Having read this I installed the Hebrew pack, but still no joy. The relevant part of the MLT file seems fine (see below) - as you would expect when it generates a correct video on export. I just can’t think what is different between your systems and mine to cause the preview pane problem!

  <producer id="producer0" title="Anonymous Submission" in="00:00:00.000" out="00:04:59.980">
    <property name="length">00:05:00:00</property>
    <property name="eof">pause</property>
    <property name="resource">#00000000</property>
    <property name="aspect_ratio">1</property>
    <property name="mlt_service">color</property>
    <property name="shotcut:caption">transparent</property>
    <property name="shotcut:detail">transparent</property>
    <property name="ignore_points">0</property>
    <property name="global_feed">1</property>
    <property name="xml">was here</property>
    <property name="seekable">1</property>
    <filter id="filter0" out="00:00:06.740">
      <property name="argument">A العَرَبِيَّة Arabic
U چھوٹی يے Urdu
K 片仮名 Kanji
H עִבְרִית Hebrew
A Հայոց գրեր Armenian
K 한글 Korean
T ཁམས་ Tibetan
C русский язык Cyrillic</property>
      <property name="geometry">0 0 1920 1080 1</property>
      <property name="family">Verdana</property>
      <property name="size">135</property>
      <property name="weight">500</property>
      <property name="style">normal</property>
      <property name="fgcolour">#ffffffff</property>
      <property name="bgcolour">#00000000</property>
      <property name="olcolour">#ff000000</property>
      <property name="pad">0</property>
      <property name="halign">center</property>
      <property name="valign">bottom</property>
      <property name="outline">0</property>
      <property name="mlt_service">dynamictext</property>
      <property name="shotcut:filter">dynamicText</property>
      <property name="shotcut:usePointSize">0</property>
      <property name="shotcut:animIn">00:00:00.000</property>
      <property name="shotcut:animOut">00:00:00.000</property>

Even weirder - I also downloaded your MLT into Shotcut on my system and although the MLT definitely contains the Persian text (I can see it in a text editor) it doesn’t show on the preview pane, NEITHER does it show in the input window of the Text filter!!

Did not install any fonts.
From the MLT provided by @sauron, just moved the text box to the left a bit.

This might be the issue:


On my computer, all of these fonts are installed via Windows 10.

  • Dengxian, Dengxian Bold
  • Estrangelo Edessa
  • Khmer UI, Khmer UI Bold
  • Lao UI, Lao UI Bold
  • Leelawadee, Leelawadee Bold
  • Lucida Sans Unicode
  • Microsoft MHei, Microsoft MHei Bold
  • Microsoft NeoGothic, Microsoft NeoGothic Bold
  • Microsoft Uighur
  • Segoe WP, Segoe WP Light, Segoe WP SemiLight, Segoe WP Semibold, Segoe WP Bold, Segoe WP Black
  • Segoe WP Emoji
  • Tahoma, Tahoma Bold
  • Urdu Typesetting, Urdu Typesetting Bold
  • Yu Gothic Bold

Per the listed article above:

Enabling optional font features without changing language settings:

If you don’t know the specific language, or if know the language of the text that is displaying incorrectly but don’t want to add that language into your user profile, you can install any optional font feature without enabling any additional languages.

From the Start menu, open Settings.
Select System.
Select Apps & features.
Select Manage optional features.
Select Add a feature.
Select any optional font feature from the list.