Hardware accelerated encoding renders video-less mp4

Reposting this to get SOME attention.

In the several projects I’ve finished since the most recent update 20.10.31, hardware encoding has always produced unusable results. I have selected “auto detect” and Shotcut selects h264_nvenc and hevc_nvenc (I assume the suffixes are manufacturer specific, with amf being radeon chips, nvenc being GeForce, and qsv veing Quadro). The projects that I have rendered with hardware encoding enabled (which do speed-up render time) produce .mp4 shell files with no video stream. The size of the file is also reduced, given that there is only an audio stream.

Im running on an Intel i7-9700K at stock speeds on a Z390 Chipset. Graphics chip is an NVIDIA RTX 2070 Super. (TU104-410)

Are these rendered with default settings?
If not Default, what preset was chosen?
Did you enter Advanced? If so, what settings did you change?
Inside Advanced, is Parallel Processing on or off?
Any filters applied to Output? There will be a funnel symbol like this one on there.

This is on default H.264 export settings, no filters. The speeds of the clips are manipulated.

What is the project resolution (video mode)? Could you attach the job log from an export that has no video stream?

Here is the job log on Pastebin.. Project resolution is 1280x720, 30.00 fps.

The log looks fine. You should make a simple test: start a new project, Open Other > Count > OK, and Export > Export File.

Unfortunately the test file is also devoid of video. Here is the export log on pastebin. Perhaps it has to do with interlaced vs progressive encoding? This one shows “No NVENC capable devices found.”

[h264_nvenc @ 00000000027bdd80] Interlaced encoding is not supported.

I think that is clear.

This topic was automatically closed after 90 days. New replies are no longer allowed.