H264_nvenc does not render in 4K

I’ve rendered 400 videos with the settings you see in the pictures, but ever since updating to the latest version, “h264_nvenc” no longer renders the videos in 4K. I can only output videos that are low quality at 5mb or less. If I change to the codec to “libvpx-vp9” I can achieve what I used to, but it takes 1-3 hours longer to render. How can I fix this?

Thank you.

Two possible problems:

What is your video card model number? It may be too old to be fully supported by newer libraries.

What happens if the quality is set slightly lower than 100%? Maybe lossless mode isn’t supported with this configuration of card and drivers.

Hey Austin, thanks for the response. I have a 4090 and I’ve done hundreds of videos at these settings on this hardware with no issues, but I will try your suggestion and report back.

It is working for me with a RTX 4070 with Shotcut 24.04 on Windows including at 100%, which is automatic and not lossless! BTW, this automatic mode is an NVENC thing (decision-making), and I find the quality to be quite poor.
For lossless, see

But also, that creates a very large file when compared with x264 lossless; I discourage usage of h264_nvenc for lossless.

From the version 23.12 release notes:

Changed all NVENC hardware encoders in Export to use CQ instead of constant QP for VBR rate control.

Because CQ is now recommended over QP for NVENC.

Any suggestions?

Use 75%, the quality will be very high without massive file sizes.

I just tested the quality with Properties > menu > Measure Video Quality, and Export > Codec > 75% gave a VMAF score of 99.995%. And this was with very shaky, fast moving, high details (FPV motorcycle ride surrounded by trees moving head to look around on a GoPro with stabilization turned off). To understand further, you can search and learn more about “lossy video compression” and the “VMAF” video quality metric.

Here is a heavily down-scaled and compressed version of that footage I described

Why you are using 100% quality settings? On my GTX1660TI I get out very good results with 65% quality settings. Everything above my hw encoder seems to does not like it (huge speed drop…).

Probably because he has a RTX 4090 :slightly_smiling_face:
I don’t know but people say it’s the best in the market right now, and also the most expensive consumer GPU :slightly_smiling_face:

I would surely set everything to 100% if I have the best consumer GPU on earth, even though it’s nonsense because I would get almost only 1% difference by setting it to 80% :skull:
Because I burned my money on that piece of sweet cookies :skull:

100% means preserving all color and texture data which does not make sense.
shutcut leader’s suggestion 75% quality is also extreme high and there will be a hardly noticeable difference in the result (I am sure I will not see any difference)

This issue is it worked reliably at 100% for 400 videos over the last 1.5 years and then suddenly didn’t work.