GUI text scaling in 4k resolution

Hi, I’m trying to use shotcut with 4k display resolution (3840x2160). Icon sizes of things like video preview screen controls and timeline buttons etc scale larger and some text in windows too. Text for tabs, shortcut icons at top left and the timeline position counter below the preview screen don’t scale and become microscopic. Any workaround for this in settings? I can have so much more going on in the GUI at this resolution but the near invisible text of the important timeline position is to aggravating so I’m forced to run my screen at 1920x1080. In pic things that scale are in green, things that don’t are in red. Any advice?

You should tell your operating system, Shotcut version, and display scale setting in system settings. Do you have more than one display?
See also --QT_SCALE_FACTOR command line option at

Thanks for the reply. I’m not a gifted PC user. I tried adding the --QT_SCALE_FACTOR in a command line prompt window but I have no idea what range the number should fall in. shotcut starts then fails to load with anything I put in if I use the – in front, if I don’t it loads but nothing is different. I tried 200, 400, 1400. It will not allow me to add it to the shortcut properties command line on the desktop icon. I am currently running 2 monitors on the motherboards onboard graphics adapter. One via VGA and the other via HDMI but It does it with just the HDMI. It does the same thing with a separate graphics card with HDMI output running solo too. The “monitor” is a 65" 4k TV with only HDMI input. (I sit across the room with wireless input devices) I don’t have this issue with any other program or app GUI than Shotcut.

If you use the search tool at the top of the page for this you will find lots of topics, one of which is:

Using a scale factor of 1.xx makes a difference 1.5-1.65 most balanced but not any better than just running video resolution lower because the work space gets smaller just the same. Greater than 1.75 starts getting ridiculously large. It seems the font size can’t change without affecting the work space size which is what I’m trying to accomplish.Largest work space without microscopic fonts. Scaling using that method scales EvErYtHiNg.

This topic was automatically closed after 90 days. New replies are no longer allowed.