Grey artifacts/screen after splitting

Hi everyone! First time posting here ^^

File format: H265 (OBS, AMD H265-preset, max quality)
Relevant PC Specs: Ryzen 5 2600, 16GB RAM & AMD RX570

Grey artifacts / grey full screen when:

  • Transition between split video;
  • Scrubbing through the timeline.

Things I have tried:

  • Downgrading Shortcut versions (from current (v19.09.14), untill early June 2019);
  • Removed all effects;
  • .H264 encoding;
  • scout the Shortcut forum.

Help please :frowning:

Screenshot during timeline scrub

What is your video mode? (Click on Master, then Properties) Resolution/FPS
What is the source property of the clip displayed? (Click on the clip, then Properties) Resolution/FPS.

Thanks for the reply!

Video mode:
Automatic (I just tried different modes but it made no difference)

Source property of the clip:
Codec: HVEC
Resolution: 1920x1080
Frame Rate: 30,00000
Format: yuv420p

EDIT: I just noticed a grey rectangular image/artifact in my my timeline both at the start and at the end of a split (screenshot OP).

Just to verify, does the source video play back properly in an external media player like VLC?

The Convert to Edit Friendly feature could be useful to determine if the problem is with the video or with the Shotcut configuration.

This is what I’m looking for.

How are you recording HEVC with OBS? Is it from a 4k capture card?

If you opened up Shotcut, new project, set Video Mode to shotcut_2019-10-11_08-47-38 ,
then opened your video file, splitting the file, do you get the same result?

No issues through my Windows video player! The source video just plays like a normal video should, with no artifacts!

I did try to import a .FLV file to Shortcut which showed no issue’s. It went perfect with no artifacts.

That said, I’m currently converting parts of my timeline to Edit Friendly…albeit it does seem to take lots of disk space and quite a bit of time. I’ll wait it out ^^


So I tried to convert a 55 second video which took ~20 minutes…but apparrently Shortcut converted the ENTIRE 55 minute clip! Well…for a 55min clip only taking ~20min sure is fast ^^ After conversion (chose the H264 version) everything works perfectly! No issues whatsoever! However, why is it having trouble with my H265 file?

My project shows the exact same properties as yours does in the screenshot!

I also did as you suggested and opened a new project, set Video Mode to HD 1080p 30FPS, then opened my video file, splitted it and still got the same issue :frowning:

I am recording HEVC with OBS. Below are my OBS Settings. It’s just the H265-preset with the bitrates upped. The bitrates (target & peak bitrate) are a bit higher now as I started recording in 60FPS instead of 30FPS yet still want to keep image quality high enough.

I can’t be sure, but it sounds like a decoding issue. There are two things to try, both in OBS:

  • Try saving as a Matroska MKV file instead of an MP4 file. The MP4 file is not resilient to any sort of interruption and the file is easily corrupted.
  • Try using a software HEVC encoder instead of the hardware AMD encoder. Maybe the AMD card is creating something that’s difficult to decode properly.

No guarantees that either will work, but it’s a start.

Thanks! Surprisingly the solution was quite easy!

I only had to change the Encoder setting from H265 (AMD) to ‘Use stream encoder.’
Now I have no trouble at all! I tested it with LoL and quality seems great, albeit less sharp than with H265.

Also, the file size is ridiculously small! A 26 minute, 1080p60 recording only is 503MB!

So far it seems like a easy fix that requires no extra encoding whatsoever ^^

Out of curiosity, what are the encoding settings of the stream?

Stream-encoder didn’t work well. I noticed a huge drop in quality. I can’t change the streamencoder settings either. It’s just ‘something.’

H264 seems to work fine (OBS used to give me an error-message, but it’s fixed now). No artifacts with Shotcut! Rendering a 6min 1080p60 project (source: OBS with settings from the SS below) only took ~2 minutes. Output quality is staggering. Better than I’ve ever seen with my previous H265 pre-set. So, now I’m happy. Quality has improved. File-size did grow a bit, but is still very small. The OBS-source files work perfectly with Shotcut now. Great, great, great!

Why H265 encoding doesn’t work in my case with Shotcut, I don’t know. It’d be nice if it’d work, but it is not necessary ^^

Current OBS-settings. Great quality, small file-size.

Sounds great! H.264 is a workhorse and usually better at retaining fine details than H.265 when not given fine-grain control of the output.

There could still be a case for putting H.264 in an MKV instead of MP4 file though. If you are doing a long capture and lose power to the computer, the MKV will be recoverable and usable whereas the entire MP4 file will be lost and have to start over.

Aha, I see. So, lucky for me I’m only working with short recordings of at most 10-15 minutes. At the moment I lack the storage space to switch over to a redundant container like MKV thus I have to continue using MP4. Quality-wise however, I am very pleased at the moment ^^ It’s a lot better than anything I’ve had ever before, especially thanks to Shotcut’s YouTube export-setting. It’s just, perfect! The compression-artifacts I’m used to with videos I upload to YouTube are all gone now :wink:

One difference between Shotcut and normal video players is that Shotcut needs to seek a lot more. Long keyframe intervals can make seeking a challenge. I would also suggest to try turning down the keyframe interval in your encoder settings. Maybe try changing it to be half your frame rate (as an experiment) and see if that makes any difference.

1 Like

This topic was automatically closed after 90 days. New replies are no longer allowed.