Green Bar/Blank Screen end of timeline


As the title states, there is a long green bar (which turns to a blank screen) at the end of the timeline to my video I am working on (see images). This makes the file 2:23 hours long instead of ~20 minutes. I have tried to research solutions but I can’t find one that helps for my situation.
The solutions on this forum were too:


  1. Split the last clip at playhead and remove everything to the right of it, but you can’t do this on the green bar portion, and when I did this to the last clip in the timeline, it did not fix the problem.
  2. I tried creating a new track to moving everything but then the new track has the green bar at the end so it does the same thing.
  3. I tried adding the In and Out points for exporting but I can’t find where the option is to only export the clip from the in and out points.

Is there anything else to try to fix this?
My other option is to export this video at 2 hours and 23 minutes and then create a new shotcut file and edit the new video to delete the extra blank space at the end.

It looks like you can simply remove track V2 to fix this problem.

In the Timeline menu there is Copy Timeline to Source. From there you can trim and then export.

That’s what happens when I add track 2, but before adding the track 2 (and after deleting it) the green bar just moves to track 1

Attach your .mlt project file to a reply.

Dalliance.mlt (464.4 KB)

Here it is! I’m not sure how well this will work since you don’t have the source videos but it is attached.

Your audio track A1 has a clip that is one frame long way out there on the right side! It was probably too small for you to see unless you zoom way in. I removed it for you. Try it now.
Dalliance.mlt (464.3 KB)

This topic was automatically closed after 90 days. New replies are no longer allowed.