Grabbing: Should I choose "interlace" or "progressive"?

Hello,

In short:
I don’t know, if the source of my Video is interlace or progressive.
I want to make a lossless Ut Video.

Question: What do I have to choose now? Progressive or interlaced?

More detailed:
My source is a USB-Videograbber of Q-Sonic. I use it to digitise my video 8 types from 1987 (Pal). As said, I do not know what the output of my Grabber is.

For my raw digital Video I want to choose Ut Video, so that I can after make my different end formats.

  1. Question: When I choose in Shotcut “progressive” when capturing, but the output of the Videograbber is “interlace”, then Shortcut will convert “interlace” into “progressive”. Right?

  2. Question: When I choose in Shotcut “interlace” when capturing, but the output of the Videograbber is “progressive”, then Shortcut will convert “progressive” back into “interlace”? Right?
    (That would mean the Video would be converted twice. First the USB-Videograbber would convert “interlace” into “progressive” and then Shortcut would convert “progressive” back into “interlace”. This would be a waste of quality.)

Thank you for your help.

With kind regards.

Download “mediainfo” from the webpage below, give it the name of your file and hit the menu item View=>Tree or View=>Text and it should give all the info you need.

https://mediaarea.net/en/MediaInfo

Thank you for your answer, but …

I am not sure, if this would help.

When I choose in Shotcut “progressive” when capturing, but the output of the Videograbber is “interlace”, then Shortcut will convert “interlace” into “progressive”. So I will have a video that is progressive. This is what mediainfo will show me: “progressive”. So I do still not know what the native output of my usb-Grabbber is.

When I choose in Shotcut “interlace” when capturing, but the output of the Videograbber is “progressive”, then Shortcut will convert “progressive” back into “interlace”? This is what mediainfo will show me: “interlace”. So I do still not know what the native output of my usb-Grabbber is.

So mediainfo would not help.

So my question of post #1 remains. Or do I miss anything?

My assumption is that you would use the software (“EZ-Grabber”) that comes with the USB grabber to copy the VHS to a file on your computer which is what you will feed into Shotcut. Mediainfo would give the information (whether it was Progrssive or Interlaced) for that file.

See below for other options:

Thank you for the link.

The method with ffmpeg seems to be what I need. Sublink: http://www.aktau.be/2013/09/22/detecting-interlaced-video-with-ffmpeg/

I will try it out.

After all my tests (see below), it looks like the output of my USB-Grabber is “progressive”.

Here is what I have tested:
Shotcut->File->open other device->capture file

I have tried out the following lossless formats two times. Once “progressive” and once “interlaced”:

  1. FFV1 with the default setting progressive

  2. H.264 with the default setting progressive

  3. HuffYUV with the default setting progressive

  4. UT Video with the default setting progressive

  5. FFV1 with the user defined setting interlaced

  6. H.264 with the user defined setting interlaced

  7. HuffYUV with the user defined setting interlaced

  8. UT Video with the user defined setting interlaced

After I have opened each of this file in Shotcut and checked the properties.

My expectation was now, that 1-4 have “progressive” as property and 5-8 have “interlaced” as property.

But I found, that 1-5 and 7-8 have “progressive” as “property” and only 6 has “interlaced” as property.

After I have in addition checked all files (1-8) with the following command in Linux to find out, if the video is “progressive” or “interlaced”:

ffmpeg -filter:v idet -frames:v 10000 -an -f rawvideo -y /dev/null -i /myPath/MyFile.XXX

The result was, that all files 1-8 were “progressive”.

An example output looks like this:

[Parsed_idet_0 @ 0x5644366acf40] Repeated Fields: Neither:   812 Top:     1 Bottom:     0
[Parsed_idet_0 @ 0x5644366acf40] Single frame detection: TFF:     0 BFF:     0 Progressive:   812 Undetermined:     1
[Parsed_idet_0 @ 0x5644366acf40] Multi frame detection: TFF:     0 BFF:     0 Progressive:   813 Undetermined:     0

-> ffmpeg has checked each frame and found in the example above, that there are no TFF and no BFF (Top Field First / Bottom Field First), but a lot af progressive.

Question 1: Why does Shotcut not show me the property “interlaced” for 5,7 and 8?

Question 2: Why does Shotcut property not show either for all of 5-8 “progressive” or “interlaced”?

Question 3: Why does the Shotcut property in example 6, which is “interlaced”, not match the analysis of ffmpeg? Of course the output of the ffmpeg is right for sure. So why does Shotcut here show the wrong property?

This is very confusing for me.
Is someone from the Shotcut team able to reproduce this?

Please take your time to read the test above carefully. And let me know, if something is not clear. Would appreciate some answers. Would be very interested. Thank you.