GoPro video playback slow

I got a GoPro Hero6 and did a video at 4k, 60fps. It plays normally in the default Windows 10 app, but in Shotcut it is very slow and stuttery. I tried setting the speed to 2.000 but that didn’t change anything. The video is HEVC codec (I don’t really know what that means).

Computer: Aurora-R5, plenty of CPU and RAM, dual GeForce gtx 1070 running at full 4k. Latest version of Shotcut. The video is fine in the Windows app, so I don’t think the hardware is lacking.

Also under settings I checked GPU processing but that made no difference.

Is there something I need to do to get it to play, or is Shotcut just not able to work with Hero6 video?


Be sure to turn GPU processing back off. That is an experimental feature for filters and you probably don’t want it.

The Windows app probably uses the video card for hardware accelerated decoding. Shotcut does not use hardware accelerated decode. That may be the difference.

You could try converting the video to an edit friendly format. In the Properties panel, click on the Hamburger Menu and then choose “Convert to Edit friendly”. It will be a very large file. Does that file play more smoothly?

1 Like

I tried the Edit Friendly option, with the middle setting. It’s better, but still seems a little lag when it starts playing. The video is 14:07 seconds, but takes around 14.79 to play (I timed it twice).

Anything else I can do? Looks like the HEVC video is just too much to handle without hardware acceleration, even with a quad core i7?

How much free RAM does your system have?

it has 16GB RAM.

That’s probably accurate. I would expect that the best you can do is enable “Settings->Realtime (Frame dropping)” and just edit through the jerkiness. Of course, when you make the final export, Shotcut will produce a good file because it will take as long as it needs to render the file. So editing will be inconvenient, but the final result will still be good.

I am coming across the same problem, did you find a solution?

Would this help?