Glitch with some values causes export crash

What is your operating system?
Linux Ubuntu

What is your Shotcut version (see Help > About Shotcut)?

Can you repeat the problem? If so, what are the steps?
(Please be specific and use the names as seen in Shotcut, preferably English. Include a screenshot or screen recording if you can. Also, you can attach logs from either View > Application Log or right-click a job and choose View Log.)
The problem is repeatable. The Glitch filter works ok during editing but during export some values seems to create crash. Basing on my tests it seems that shotcut doesn’t accept block height equal to 0.0 or to equal to 0.1 but when setting it to 1.0 or to 50.0 export is fine.

Just in case:
Empty block with one colour with filter Glitch: Frequency=100, Block height=0, Shift intensity=100, Color intensity=100.

Code example (object copied to clipboard):

<?xml version="1.0" encoding="utf-8"?>
<mlt LC_NUMERIC="C" version="7.13.0" root="" parent="producer374" in="00:00:00.000" out="00:00:01.967"><producer id="producer374" in="00:00:00.000" out="00:00:01.967"><property name="length">04:00:00.000</property><property name="eof">pause</property><property name="resource">#FFFFFFFF</property><property name="aspect_ratio">1</property><property name="mlt_service">color</property><property name="mlt_image_format">rgba</property><property name="shotcut:caption">#FFFFFFFF</property><property name="ignore_points">0</property><property name="xml">was here</property><property name="seekable">1</property><filter id="filter2283" out="00:00:01.967"><property name="version">0.1</property><property name="mlt_service">frei0r.glitch0r</property><property name="0">1</property><property name="1">0</property><property name="2">1</property><property name="3">1</property></filter><filter id="filter2284" out="00:00:01.967"><property name="lift_r">-0.30901</property><property name="lift_g">1.5259e-05</property><property name="lift_b">-0.812009</property><property name="gamma_r">0.644999</property><property name="gamma_g">1.00002</property><property name="gamma_b">0.217014</property><property name="gain_r">0.454264</property><property name="gain_g">1.00003</property><property name="gain_b">0.00108834</property><property name="mlt_service">lift_gamma_gain</property><property name="disable">0</property></filter><filter id="filter2285" out="00:00:01.967"><property name="background">color:#000000ff</property><property name="mlt_service">affine</property><property name="shotcut:filter">affineSizePosition</property><property name="transition.fill">1</property><property name="transition.distort">0</property><property name="transition.rect">240.356 135 1440 810 1</property><property name="transition.valign">middle</property><property name="transition.halign">center</property><property name="shotcut:animIn">00:00:00.000</property><property name="shotcut:animOut">00:00:00.000</property><property name="transition.threads">0</property><property name="disable">0</property><property name="transition.fix_rotate_x">0</property></filter><filter id="filter2286" out="00:00:01.967"><property name="start">1</property><property name="level">1</property><property name="mlt_service">brightness</property><property name="shotcut:filter">brightnessOpacity</property><property name="alpha">00:00:00.000=0;00:00:01.000=1;00:00:02.000=0</property><property name="opacity">00:00:00.000=0;00:00:01.000=1;00:00:02.000=0</property><property name="disable">0</property></filter></producer></mlt>

I did not recreate that problem with version 23.11.29. Can you test with the latest version? I suggest to save a copy of your project to open with the portable version of Shotcut from here:

I tried to create mini project with copied elements to re-create the problem in 22.12.21 and I have problem as in other project it works… It might be some strange correlation of many layers, perhaps sth with alpha channels etc. One thing is sure, turning off glitch filter makes export possible. Do you always initialise fully glitch filter with every use or do you use sth from previous usage in the project?

Just before crash the log shows sth like that but not sure if it helps:

[filter swresample] 2(stereo) f32le 96000Hz → 2(stereo) f32le 48000Hz

[h264 @ 0x7fea5f56eb00] Reinit context to 3840x2160, pix_fmt: yuvj420p

Automatically inserted bitstream filter ‘vp9_superframe’; args=‘’

[h264 @ 0x7fea5c30e7c0] Reinit context to 3840x2160, pix_fmt: yuvj420p

Failed with exit code 4

Export job failed; trying again without Parallel processing.

I have not seen error code 4 before. Have you tried without parallel processing? (Disable it in the advanced export panel).

As the video is quite long in total thus I didn’t try it as the whole without parallel processing. Although I did some additional testing and that behaves really strange. Some examples:

  1. If I export ex. 10 sec fragment only, sometimes this block with glitch is exported fine without parallel processing but it’s not exported with parallel processing.
  2. I also found some blocks having glitch with block height =1.0 which caused problems. When i deleted them and copied once again the same blocks from another copy of the same project, they suddenly were successful in export both with parallel processing and without parallel processing.

Btw, do you know why sometimes why i cut the block, the following blocks move left in the way they would try to filling the missing place

Maybe you have ripple enabled

No, it’s not the case. I noticed that it’s the difference between cut (Ctrl+X) and delete. Cut causes moving elements on the right to move. Not sure what is the idea behind this…

I made some more experiments with 22.12.21. Definitely it’s somehow related with glitch filter and parallel processing. I exported the video in non-parallel mode and although it took ages, the export was fine (in the old version with problems). But even this new version for which it seemed that I removed the problems didn’t want to export fully in parallel mode. I’m confused…