'Glitch' filter does not applied in exported video

Hello. I searched in Google and browsed through FAQ and forum, but didn’t encounter similar problem.

Win10 Pro
Shotcut ver. 20.11.28 64x

So the problem is, I apply ‘glitch’ filter to an image and in project preview it works just fine. But after exporting video this image does not glitch at all, as if there is no filter applied… This image also have ‘fade out’ filter and it works just fine.
Export settings are standart, I didn’t change anything except for trying ‘parallel processing’, didn’t help.
Am I doing something wrong or is it a bug?

@Shepard_John Did you apply any other filters?

Can’t reproduce. Glitch filter works fine for me.

Windows 10 Home
Shotcut 20.11.28

Steps I took.

  • Video Mode: 1080, 60FPS
  • Opened image and placed on V1 in the timeline
  • Glitch filter (default settings)
  • Fade Out Video filter (default settings)
  • Export (default settings)

I probably found what was causing problems. I tied filter settings to key frames, but after deleting filter, adding it again and leaving standart settings it worked just fine.
Full setup of my project is like this:
lower timeline is video without effects
upper timeline is my picture with fade out, glitch, frame size and blend mode filters. Picture is visible for around 3 seconds, glitch applied for approximately one last second. Previously glitch parameters was rising over that last second, now they stay constant.

You can also trim each filter in the Keyframes tab.

Yeah, that’s exactly how I did it this time.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.