Freeze on load


I’m running the latest version of Shotcut on an Ubuntu 20.04 machine.

I worked on a work project all day, saved regularly, managed to do a few exports.
And at some point, Shotcut froze and shut down (nothing big here, it happens sometimes) but now when I try to load into my project again, it just freezes again and shuts down.

Reparation failed and it just freeze when I try to load the original project.

Other projects open just fine but this is the very one I need badly…

By looking at my system monitor, I noticed Shotcut seems to use only one out of my eight CPU units. It obviously tops at 100%.

Any clue or hint of what I could do about it?

Here’s the project:
insecurity_interview.mlt (375.8 KB)

Thanks a lot in advance.

I do not own a Ubuntu, but telling your shotcut version and system specs is something useful and plus have you checked how much ram it took of your CPU Or laptop. I am currently at a place where I don’t have access to my PCs (and it’s my grandma’s house), So I can’t open the mlt project right now, but my best guess is that your project is filling up your ram that’s why it’s crashing.

I actually don’t know this thing, and as it’s a Ubuntu, there are different ways to solve this problem from a windows or Mac. So even if I knew the answer, then I would have been only knowing the answer about Win and Mac.

The project file says version 21.03.21 - a version number is always more meaningful. There are newer versions but not yet recommended for stability.

<property name="resource">insecurity_interview.mlt</property>

Your project includes itself. Obviously, that is not a good thing. We try very hard to prevent you from doing that, but somehow it happened. I tried to manually fix it for you:
insecurity_interview - fixed.mlt (375.0 KB)

Thank you! I’ll make sure to do so next time!

I just tested your fixed project and it seems to work perfectly (it opens at least!). Thanks a lot!

What do you mean by the “project includes itself”? How did I manage to do that?
I’m a beginner, so maybe it’s a thing I’m not supposed to do that I’m not aware of?

Thanks again! And thank you @Ar_D as well!

Possibly you dragged your project file from your file manager to the timeline and dropped it there. There is supposed to be code to reject that and sometimes show a dialog like “You cannot add a project to itself!” I just tested this on macOS where I am at the moment and could not make it include itself. If you figure out how please let us know. Thanks

If I did that, I think it’s nothing more than a keyboard error or a dubious mouse drag… :confused: But I’ll let you know if I find any clue about what happened.
Thanks a lot again for saving the day!

This topic was automatically closed after 90 days. New replies are no longer allowed.