Fonts: how to turn off antialiasing?

Hi,
Is there any way to turn off antialiasing in the project (for all Test:Simple filters)? I’ve looked on the results and it doesn’t look well. It might be somehow related with the fact that antialiasing is not done with color of fond and background but with color of font and black? Or perhaps is that some kind of bug? (Outline is set to 0 in Test: Simple filter)

Do you have a fully opaque clip on the track below the text filter? The text background opacity does not work well if there is transparency in the clip below it.

Yes I did. However after your post I’ve added additional black colour track below and it’s the same. When doing antialiasing instead of “combining” only two colours from Text: Simple filter, in this case font and background, it adds additional third black colour. The result is very ugly. Not sure why… In my humble opinion it’s a bug…

I did quick searching and please have a look on this example and this green ball: https://blenderartists.org/uploads/default/original/4X/7/0/5/705baefc201cfac0e766ee3d8dcada43d02517b4.png They mix only two colours here: dark and light green within antialiasing procedure. However shoutcut would add here third black colour in between.

Do you do antialiasing procedure by yourself or do you use something “from the shelf”? What are the parameters of this procedure?

That is a complicated question. QT does the antialiasing of the font, and the MLT engine does the compositing.

Can you provide more information about your project?

Operating system?

Shotcut Version?

Some screenshots of: Your timeline, your preview (so we can see the problem), your clip properties, and your text filter parameters?

There is no way to turn off anti-alias. But you can use another program to make text without anti-alias on whatever background you want.

The effect you are seeing is probably due to Shotcut does not blend images in linear light color. Rather, internally RGB is sRGB, and Y’CbCr is ITU-R BT.601 or 709. All of these have gamma. This is a known issue that is not a simple bug fix in one place. There are lot of implications including performance and affecting the results of various filters that would alter existing projects. That is not to say it will never be addressed just not sure when.

Thanks for explaination. However I can’t imagine making text in external program. It would mean a lot of work. Moreover anti-aliasing is basically a good thing assuming it works correctly.

Is there this on the list of bugs? If not, what about changing this thread from How to to Bug? Even if it might be challenging “to repair”.

When having a bit more time, I might do some additional experiments. Perhaps it might lead to some workaround or some suggestion how to quickly fix it.

Linux Ubuntu / Shotcut 22.01.30 and 22.11.25

I prepared short project presenting this problem and just in case to avoid that it’s somehow related with operating system and not the Shotcut itself I also exported one frame. Please have a look on it in Gimp (or other software not modifying the presented image when zooming as some are trying to improve the zoomed image) to see that characters are white and background is red but… there is surprisingly some kind of borders of black colour being result of antialiasing (even when border is set to zero).

Link to project: 2022.12.07_Antialiasing.zip - Google Drive

I also tried to find some workaround but I’m not able. It seems that changing parameters doesn’t have any impact on this small black frame…

One thing more which come to my mind. When executing the procedure used for drawing text, can you select what antialiasing algorithm is used? Perhaps it’s worth to check with other algorithm or other parameters of this algorithm?

I’m sorry for returning to this a bit older bug. Might I ask if anything is happening here? If it’s not easy, as it was said, is there any chance to add the option “antialiasing on/off”. That would be an easy workaround…

No, the color problem I mention is a huge project that has major performance implications and project/filter compatibility but is on the road map, and quite frankly may never get done. It is not limited to text, and it is not anti-aliasing.

How other video editing software is solving this?

1 Like

Now it’s more clear. From one side I fully agree it’s quite challenging/risky area. From another I personally believe that more focus should be put now on improving Shotcut and mlt in the existing functionality, in particular to fix different types of bugs and probably increase a bit productivity (ex. adding some simple gui improvements) than on adding new functions. But it’s just my humble opinion.

Moreover it would be easier to introduce such risky changes if better testing was implemented. Please correct me if I’m wrong but I guess that mostly it’s only manual testing by authors and users (both for Shotcut and mlt). For project of this size, a new approach for testing and possibility to introduce at least partially automatic testing could be analysed. Although I know that it’s easier to say than to implement and that goes beyond this thread about blending bug.

I still keep my fingers crossed for fixing this problem…

This topic was automatically closed after 90 days. New replies are no longer allowed.

Here is an example made with GPU Effects in the next version where color processing is all done with linear color images. In order to do this, you can only use text on a totally transparent clip. Otherwise, the foreground and background colors compositing is done within Qt, which is not working with linear color but rather sRGB. After modifying the project to have the same red color on V1 and changing the properties of the clip on V2 to transparent and then export frame.

Zoomed in before

after

2 Likes