Folder access on Linux

Shotcut versión 21.06.29

Operating System: Ubuntu Studio 20.10
KDE Plasma Version: 5.19.5
KDE Frameworks Version: 5.74.0
Qt Version: 5.14.2
Kernel Version: 5.8.0-59-lowlatency
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-7400 CPU @ 3.00GHz
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2

In version 21.06.29 the inclusion of the icon to add files to the playlist is great.
Clicking on this icon takes you to the file explorer.

The loading of a mask file can also be accessed from the customize menu of the mask filter from file.

However, it is still not possible for me to access the folder of an exported video from the context menu in the task window (show in folder).

I thought it was a general file explorer access problem, but after a bit of checking I found that:
Set proxy storage folder opens file explorer window, but if I choose to show proxy storage folder, it does not open (my OS uses Dolphin).
The same happens with the application directory.
The file explorer doesn’t work but by clicking set instead, the file explorer appears correctly.
I’m just commenting in case this might help resolve this.
could it be that the file explorer opens fine when the path is preset before and doesn’t open when the path depends on the location chosen by the user (e.g. for export)?

Are you referring to the “Show in folder” option in the jobs context menu?


I use Gnome 3.36.8 on Ubuntu 20.04.2 and it works fine. So maybe it is a KDE issue?

Yes, that’s what I mean.
It also happens in the other examples I gave above.
It could be what you say, a KDE issue.
I think this has always happened in Ubuntu Studio since I started with 20.04.2 LTS.

Do you use the portable tar, AppImage, or snap? I wonder if there could be a difference between those?

I tested with the portable tar.

I tried AppImage although it also happens in Snap in the stable version.
I will try to learn how to use portable tar to test it on my operating system.

It is well known that Show in Folder is unreliable on Linux and depends on various factors, some of which I do not know. But Show in Folder is something different than a file dialog, which is reliable.

Testing, I found that in version 21.06.29 Appimage access to folders is different from version 21.06.29 Flatpack.
AppImage: does not allow access to “show in folder” but allows to set up for example the proxy storage folder (in the case of editing without creating projects).
In the video, I try to set a Proxy storage folder of my choice.
A folder selection dialog appears and I am able to complete the selection.

Flatpack: allows access to “show in folder”, however when I want to set a proxy storage folder (for the case of one-off video edits where I do not create a project) the dialog does not allow me to select the folder of my choice, but the dialog looks for opening a file instead of selecting a target location.
I try to set the proxy storage path, but it opens a file open dialog (unlike the AppImage version which opens a folder selection dialog) and I cannot complete the selection.

I do not experience this problem with Flatpak. Mine has a different dialog than yours. Flatpak is doing some desktop integration, and it uses a GTK+ dialog on my GNOME Shell. It looks like you might be using KDE. The AppImage is failing a desktop integration and showing a fallback Qt-defined dialog. There is an option to not use so-called native (integration) dialogs, and I can enable that for Linux, but someone not using AppImage will likely report that as a bug. This looks like a flatpak-KDE integration bug, and it might already be fixed. I did have to make a similar workaround for Snap packages to prevent the native dialog integration for a different problem, and I can do that for Flatpak but I may not be able to detect KDE integration specifically such that it will affect non-KDE users too.

1 Like

Yes, in my case it is KDE.
I’m just reporting to make these situations known.
It’s not a serious problem for me and I’m just showing it to report it.
Thank you. :slightly_smiling_face:

This topic was automatically closed after 90 days. New replies are no longer allowed.