Flickering or stretching of video

When I am finished editing my video, I export it as a mp4 and it has parts that flicker

Green or stretch up and down. What can be done?

Does your project file include multiple .mlt files imported as clips? It can cause exporting errors sometimes to do this. I would try testing a different project out using more direct media, rather than keep loading other .mlt files as clips. If that still causes errors let us know.

Edit: Also try disabling GPU processing if you are using it, and try using one of the H.264 profiles for exporting.

1 Like

I had the same problem and changing to H.264 solved it for me. Many thanks.

thanks lauren, i’ll keep that in mind

I just attempted to export my first project. Originally, I tried whatever was stock settings and the video was very poor quality (video and audio). I changed the resolution 1920x1080, aspect ratio 16:9, frame rate to 30, and increased the Quality to 70% (from 60%) in Codec tab. Now my videos are green hued. What happened? How can this be fixed?

More importantly, what are the characteristics of the source video?
I routinely export my video using the app’s defaults and always get good quality output. But I make sure I use compatible output settings relative to the source.

The source were CamStudios created short clips. They all looked fine when viewing them individually. Only after exporting them with Shotcut did these issues arise.

Thanks, but that’s not what I mean’t.

Codec, format, framerate, bitrate, resolution of the source video.

So, the best I can see (and not being very familiar with CamStudios either), the Video Options are:
Compressor: Microsoft Video 1
Quality: 72
Set Key Frames Every 100 ms
Capture Frames Every 5 ms
Playback Rate 200 f/s
Auto Adjust uncheckes
Lock Capture and Playback Rates checked

This was based on a youtube video as initially a 2 min video was over 2GB in size.

Increasing the resolution, aspect ratio, and frame rate is unlikely to make it look better. It may have caused the problem. You need to figure out and use the resolution of the original CamStudio video. Shotcut can do that by clicking Properties with the clip loaded into the Source tab of the player. You should try again by ensuring Export resolution matches and boosting only the Codec > Quality to 70% as you did before.

If your Settings > Display Mode is Automatic, then an existing project’s mode was determined by the first thing you added to either Playlist or Timeline, which ever came first. See the blog post for v17.11 where there is something now labeled “Master.” That block is clickable on older versions. When you click and select it on an open project and view Properties, it shows the project’s resolution and frame rate. Also, Export defaults to these values. If you added a picture or music as the first then, then it needs some mode and chooses 1080p 25 fps.