Flickering in slideshow with Blur added to pictures

What is your operating system?
Windows 10

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?

Can you repeat the problem? If so, what are the steps?
when I put pictures to the timeline as slideshow and then add a “Blur:Pad” filter to them, there is a “flickering” on the left hand side of the screen

during the transitions between the slides. This happens with and without hardware acceleration.

Please try a new export with Export > Video > Parallel processing turned off.

If the problem still occurs with parallel processing off, then please share the video mode that you are using. It it easiest if you can share your project file (or a reduced project file that exhibits the problem).

Hi Guys
I tried to reproduce it with a new project and failed on that. So I had to downsize my existing project and have now an example where the issue occurs. Now interestingly I realized that it’s not in particular during the transitions (which is what I thought when raising the issue) but during the “stable” phases of the clip. Also - interestingly - I had the impression that it’s not happening with each rendering, as a I also had a run where everything running smoothly. I also tried to replace the image with other pictures, but then the issue went completely away. So the only thing I can image is that it may additionally maybe depend on the aspect ratio??

Not sure whether this helps you reproduce…flickering.zip (2.1 MB)

Best regards,
– Christoph

Ah - and by the way - it happens with or without parallel processing on my machine.

– Christoph

Thanks for providing the project files. Unfortunately, for me, when I export the project I do not see the symptom.

I opened your exported file in shotcut to investigate it with the zoom tool. Here is what I see:

This is a zoom of frame 12:30 right on the line between the original image and the part that is being added by pad blur - everything looks normal.

This is a zoom of the frame (12:31) which exhibits the flicker on the left side of the screen. But look at the first column of pixels in the “original image” side of the frame - it is all black. The Blur Pad filter picks up that black pixel and blurs it onto the left side - causing the flicker.

There is another interesting artifact on frame 12:34 that does not result in the flicker. In this image, there is a single row of black pixels at the TOP of the original image:

This evidence makes me think that the Size, Position & Rotate filter might be occasionally changing the perimeter of where it draws the original image in the frame. One thing you could do to prove that theory would be to open your project and increase the rectangle of the Size, Position & Rotate filter to “zoom out” the image by a little bit. Even one pixel in each direction might do it. I don’t mean to suggest this as a permanent solution, but if you can try this test and the symptom does not occur, then we can feel confident that the issue is coming from the Size, Position & Rotate filter.

@shotcut, I wonder if this change might fix this problem?


I tried to select the filter, however - when I select the rotate filter, the issue goes away!

Now: I can reproduce it even when not rendering by using the project I uploaded: maybe that works for you too:

(1) just open the project, then
(2) put the mouse in the “Current position” field and
(3) enter 13:23, then
(4) hit the enter key.

Then it looks as shown here:


Same happens if I enter 13:30 or 13:37. Interestingly, the difference between the three times is always 0:07… There seem to be certain frames - as you wrote - that are affected. Could that be the effect of e.g. a floating point rounding issue?

On the steps you proposed: When I select the clip then in the timeline and then the rotate filter, the dark bar goes away - very strange. Concerning the extent of the filter: when I click it, Shotcut doesn’t show me the typical handles for the filter: am I doing something wrong here? And yes, I see this single row of black pixels sometimes too; just can’t figure out exactly when.

Best regards,
– Christoph

The handles are outside of the preview screen. You have to use the zoom feature in the preview player to zoom out to 25% or 10% to see the handles.

Ok, got it: I can see the handles. However - as soon as I select the clip, the issue is gone when the handles are being drawn.

That is a good clue. I have found that if I am careful to not load the filter window when I open your project then I do see the problem with your project file.

I see that too, now. Some kind of rounding error would make sense.

While your test file causes a problem for me, I have not found a sequence of steps to create the problem myself. This is important to be able to debug and see the problem occur (and if a potential fix is working). If you are able to provide a simple list of steps to produce the problem, please share.

I also observe that your project video mode is odd:

  • Width = 2704
  • height = 1520

Is that intentional? Or is it a side effect of using an automatic video mode? I am not sure what your goal is for your final video, but I would suggest to use a standard video mode. I even wonder if that is contributing to the problem.

The video mode is the resolution in which my GoPro natively records to avoid any loss of resolution: https://helpwiki.evergreen.edu/wiki/index.php/GoPro_Hero_4_Operating_Guide#VIDEO_RESOLUTIONS

Yes, if I find a repro, I’ll share it with you.

– Christoph

I am not sure whether this helps:

(1) while trying to reproduce I managed to get a weird constellation where the Blur: Pad filter seems to work correctly but as the picture itself gets a black frame when I deactivate the “Size, Position & Rotate” filter, this looks exactly as the issue I originally faced - except that the causing black frame around the picture is not 1 pixel but quite a few (maybe 10-20?).

(2) Now when I enlarge the problematic frames in the project I uploaded, there’s also a 1-pixel wide black frame which is the cause for the blur filter showing the flickering.

(3) In conclusion: as the “Size, Position & Rotate” is deactivated in (1), it’s most likely not the issue.

In case it helps, I can also upload the project under (1). And yes: it’s also using the custom 2.7k video mode.

– Christoph