Filters on an Audio/Video Device cause indefinite hang

OS: Windows 10 (most recent update as of writing 10.0.19043)
CPU: Intel i5-6500 @ 3.20GHz, 4 Cores, 4 Logical
GPU: Radeon RX480 8 GB
RAM: 16 GB

Shotcut Version
22.09.23 64 bit, installed with the windows install tool found here.

shotcut-log.txt (37.7 KB)

Steps to reproducing the problem

  • Open Shotcut

  • Select ‘Open Other>Audio/Video Device’ in the toolbar

  • Set ‘Video Input’ to ‘None

  • Set ‘Audio Input’ to ‘Microphone’ (in this case HyperX Quadcast)

  • Click ‘Ok

  • Click the ‘Filters’ button in the toolbar to open the filters window

  • Click any filter from the ‘Video’ or ‘Audio’ tab in the filters window

  • Shotcut freezes

    • Window is marked as (Not Responding) by Windows
    • Microphone playback continues for several minutes if left on before also cutting out

What I have tried:

  • I have let Shotcut try to recover but it never does

  • I have uninstalled and reinstalled Shotcut

  • I have updated and restared my computer

  • I have tried all the available ‘Video Input’ and ‘Audio Input’ combinations for the ‘Audio/Video Device’ and each of them hang

  • I have changed ‘Settings>Display Method’ to all available options: Automatic, OpenGL, DirextX(Angle), Software(Mesa) and the problem persists

  • I have tried many filters (though admittedly not all) and all of the ones I have tried have hung on the ‘Audio/Video Device

  • I have checked all other options from the ‘Open Other’ tab and each accepts filters without hanging

1 Like

I recommend that you capture to a file and filter the result. In case you are trying to adjust the volume for a better recording, use your operating system controls. In fact, the record audio in timeline feature does not let you add filters, and this is generally a better tool to use for recording audio. This issue is low priority for us.

This is one of the most well-written bug reports from a non-regular member that I have seen in months. The “What I have tried” section is so refreshing to see that I’m taking time to praise it in hopes that other users will follow suit.



@Jenny_Rotelli, this bug might not be fixed right away but please don’t let that discourage you from reporting on any other bugs you come across in Shotcut. Posts like the kind you wrote up are the ideal for developers when they get around to bug fixes. Thanks for taking the time to contribute. :+1:

This is fixed for the next version by blocking the addition of filters to a device or any kind of non-seekable source. That might not be what you wanted, but filters are likely to cause dropouts anyway during capture, and I was not able to debug it fully. Ever since keyframes was added there is a lot more complexity and interaction between components that needs to understand time offsets and durations. So, it is better for now to prevent the bad behavior that might cause one to lose work.