Filters "levels" and "Colour Grading": histogram

What is your operating system?
Linux 64 bit

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?
21.05.15 Flatpack. I do not know, if it’s 32bit or 64 bit.

Can you repeat the problem? If so, what are the steps?
My video is in the timeline.
I have added the filter “levels” to a clip.
I have displayed the histogram in the top left.
I have added the filter “colour Grading”.

→ When I adjust the settings in “Colour Grading” then I can see a change in the histogram.

Pleas click the GIF-animation:
Tonwertkorrektur und Colour Grading

I like it how this works.

So I wanted to have the same in another Clip.
So in another Clip I have added also the filter “Levels” and with histogram.
Then I have added “Colour Grading”.
→ But when I now adjust the settings in “Colour Grading” the histogram does not show any change.

Please click the GIF-animation:
Tonwertkorrektur und Colour Grading-2

Why does this behaving different in this two clips? Is this just buggy? Or do I miss anything?
Would be very interested in this.

Thank you.

The order of filters is important.

In your first example, the Color Grading filter is ABOVE the Levels filter in your list of filters.

Try putting it above also for your other clip.

1 Like

Thank you MusicalBox. Yes this works. Is this “order behaviour” wanted?

It is. In many cases it is convenient to get different effects, depending on the filters order.

Thank you.

Here’s a simple example, using the Glitch and the Size, Position & Rotate filters.
In the first part, the SP&R filter is on top of Glitch, in the second part, Glitch is on top.

2 different effects, using the same filters with the same settings.

1 Like

Good example. Thank you.

1 Like

You can see a live histogram (with separate colour channels as well as luma) at the current playhead position on the timeline without adding a filter to a clip by enabling a histogram window:
View menu → Scopes → tick-select Video histogram.

1 Like

Thank you. I was not aware of this.

This topic was automatically closed after 89 days. New replies are no longer allowed.