Filters "Glitch" and "Old Movie: Projector" dont respect the set Frequency

I have following Values set for these two Filters:


Old Movie: Projector

And you can see that the frequency values are very low. But in the resulting Movie the Filters are getting crazy:

Why is this happening? Is this a bug or is this “bad filter configuration”?

EDIT: In Shotcut the Filters are correctly used and “slow”. But as soon as the Movies have been exported the Filters are as shown in the Youtube-Video.

The glitch filter always works at a speed that is equal to the FPS of your project. It really upsets me that the glitch turns into an insane strobe at 60 fps, and there is no way to adjust this. The only way to make a slower glitch effect is to render the fragment with a low FPS value.

So this is a bug. Because it has its own “speed” setting with the frequency.

The glitch filter has no speed control. You can only adjust the intensity of the effect, the width and slightly control the colors. Unfortunately, the filter does not have controls for the speed of the effect. I hope someday developers will add such a slider.

What is the Frequency-Parameter for if not for speed?

For me it says “how frequent should this filter be applied” so this IS the speed of the Glitch-Filter. And it doesn’t seem to work properly.

EDIT: And in Shotcut itself this Parameter is in fact controlling the speed but like I said in the beginning it isn’t respected for Export.

No, this parameter is responsible for the intensity of this filter. At low values, glitches just appear rarely, at high values - almost constantly, but this parameter does not affect their speed in any way. Speed is ALWAYS tied to FPS. Each new frame, the glitch generates a new glitch.

" Frequency is the number of occurrences of a repeating event per unit of time." (Frequency - Wikipedia)

And yeah I thought that it would be obvious that I am not talking about speed of motion but of occurrences of the Glitching-Parts.

And once more this Parameter IS controlling the Amount of Time between these Glitches and this dont seem to be tied to FPS as the FPS is the same for the Video in Shotcut and after Export (30 FPS).

I can see that. So stop telling me this isn’t true :smiley:

The resulting Export ! IS ! different than the preview in Shotcut. And this should never not be the case. Even if there is randomly generated things. I should always get the same result as the preview. Why would we otherwise need the preview? :smiley: To see how it could be if the weather is good?

Okay, maybe we misunderstood each other :grin:
I see the same thing in the preview window as in the exported video. But this is true for non-heavy regimes. If I set 60 fps in the project settings, my computer does not have time to draw 60 frames in real time in the preview window, and only in this case I see the difference. If you see the difference too, your computer may just not be able to handle live previews.

So here is the version with 20 FPS just to prove you wrong :slight_smile:

Just want to maker sure that this has not been resolved yet…

I did a test with both filters. In my tests, the export matches the preview in Shotcut.

Most of the “crazy” effect you see in the export is the glitch filter. You have the frequency low, but the other values are at 100%. If the filter is too much, then turn the other parameters down as well. As a test, set them all to 0 and you will see that the filter has no effect.

I think you need to spend more time experimenting with the filter and learning what each parameter does. If the effect is too much, then turn the parameters down more.

1 Like