Filters don't save

Hey there! I am new to Shotcut and am running into a problem.
Among other filters, I am using the brightness filter. I’ve been working on the project for the third evening in a row, and some of my filters are reset. For example, I set the brightness filter to 140%, I save the project, I load the project the next day, and the brightness is set back to 100%.
Does anyone know if there could be something I’m forgetting, doing something wrong, or if it’s a problem with Shotcut?
Looking forward to your answers!

Not sure of why you are having this problem as I have not come across it, but as a matter of course I always press Ctrl+S each time I make a wanted change as I edit. It’s also a good idea to make a copy of the *.mlt at some points. Just belts’n’braces precautions for important work.

Thank you for your reply. Indeed it’s also a precaution I always take, so it can’t be that I’m not saving unfortunately. All other things are saved, even the filters themselves, except for the specific filter settings (like brightness on 140% instead of the default 100%).

Odd. I just ran a test, added 70% brightness. Saved the .mlt and closed shotcut.
Double-clicked the saved .mlt and shotcut opened with the brightness filter still set @ 170%.
I even opened the .mlt in an older version with the same result.
I wonder if it’s a certain combination of filters? Can you show a screenshot of the applied filters list?

Hi there. I´m also new to Shotcut…on an accelerated learning curve-by need. Am having exactly the same problem…I add a filter and then save the .mlt file but the filter setting isn´t saved; rather it reverts back to the default setting. The filter I´m using is very simple: GAIN/VOLUME setting is lowered across the video clip. Anyone come across the same issue?

What version of Shotcut are you using?

Hi. I´m on v18.07.02 - have tried several times to update to the latest 18.08.11 (including a full uninstall, deleting Shotcut registries and reinstalling) to no avail. Not sure whether anyone else has had this prob (running Windows 10, 64bit).
However, DRM, I found a workaround to the filter saving problem:
I made the filter mods on the fly with the clip to be filter-modified in SOURCE, leaving the insert point ready in the DESTINATION clip. Then simply inserted/overwrite in the master destination clip without any other changes at all. It kept the filter settings as I tested it: left Shotcut, restarted and the new filter (volume) settings were included (in the inserted clip in the master).
There´s almost always a workaround…problem is it takes a hell a lot of trial and error! Always easier to ask if someone else has had the same prob.

If your project makes use of the Playlist or Timeline, then whatever is in Source is NOT saved. Source is not a viewer of something selected in the Playlist or Timeline. It is its own container like Playlist and Timeline and you have to copy things to and from it (or open a media file). Now, with that said, if you do NOT make use of Playlist or Timeline and save, then it will save whatever is in Source, and that is called a clip-only project.

Sorry I didn’t reply. I ended up removing the program from my computer due to this problem. Thanks anyway.

Ah, OK that clears it up.
Well personally, I´m pretty happy so far with Shotcut…even with these learning glitches…I tried Adobe Premiere Pro and it was a pain…for starters it couldn´t even read my .mxf files (which I´ve since found out are industry standard…Shotcut reads it off the bat)…it requires a converstion to MPEG2 HD to incorporate…so they all have different types of issues…like pretty much any program…there´s a learning curve in everything! At least that´s my experience.
Thanks again Dan.