File Export is hanging and do nothing

Hi All,

I have edited a video but I cannot export it. I want to use only the default setting for the exporting but it’s hanging with 0% (I am waiting for ~3-4 hours).

I have checked the log of the export but it’s empty.

The used operation system:

NAME="Linux Mint"
VERSION="19.1 (Tessa)"
PRETTY_NAME="Linux Mint 19.1"

The content of version file of Shotcut:

vmaf df6b6696befa59fd6cb165f9d2786168815714b0 v2.3.0-94-gdf6b6696
aom 287164de79516c25c8c84fd544f67752c170082a v3.2.0
dav1d 7b433e077298d0f4faf8da6d6eb5774e29bffa54 0.9.2
zimg 71e6c2a32b27a4ee5f69856b8a05bbc7808de90c release-3.0.3-46-g71e6c2a
rubberband 445f20fa4cee02789ad737e970de02e00502c69c v2.0.1
vid.stab f9166e9b082242b622b5b456ef80cbdbd4042826 v1.1.0-48-gf9166e9
ladspa b0c0b9261819bc9bc9d9f392b49ff177285cc0f9 v0.4.17-39-gb0c0b92
nv-codec-headers 56bdfba4af9485d42303fa7a370b2aac176ab9f3 n8.1.24.13-2-g56bdfba
opus e85ed7726db5d677c9c0677298ea0cb9c65bdd23 v1.3.1
libvpx 626ff35955c2c35b806b3e0ecf551a1a8611cdbf v1.11.0
x265 02d2f496c94c0ef253766b826d95af3404b2781e 3.4-28-g02d2f496c
x264 5db6aa6cab1b146e07b60cc1736a01f21da01154
movit dccf5339b33ec0608a36c468cb42d38fd4fca9dd
frei0r febd73874dab6be330398a3b55112451b36ee939 v1.7.0-28-gfebd738
FFmpeg 3e539d11e4a78d44e8d95cef1d67d67e00258e31 n4.4.1-49-g3e539d11e4
mlt 4b19d02975a11b99d645ed1431460a7f63b88b2e v7.4.0-25-g4b19d029
shotcut 05b24fa529f1d6c0a7193f1e0411f6be38b617ee v22.01.17-22-g05b24fa5
bigsh0t 8fe56f6d4e0deb93ac0eb0bc73fdbe35bd7614cb 2.5-6-g8fe56f6

I am running the software in terminal but I cannot see any error on STDOUT in Terminal:

Based on the Terminal log, I think I have enough RAM and resources for the export.

Does anybody have idea what can/should I do to export my video?

Thank in advance!

I do not reproduce it on Ubuntu 20.04.
How are you starting Shotcut?
Right-click the export job and view log. What does it say?

I have double clicked the shotcut file in the folder and select the Run in Terminal option. As I mentioned in my question the pop-up log window is empty so there is any log for the export (It’s visible in the below picture [Sorry for Hungarian language on UI]).


I can see the melt-7 process is running with top command:


Maybe it has a problem with your project. Make a simple test by opening a short video and exporting. Also, try turning off hardware encoder and parallel processing inside Export if those are on.

The default export config is used. The hardware encoder as well as parallel processing is disabled.


Maybe there is a problem with the location that you are trying to export to. Perhaps try to export the file to a different location?

I have tried other location to export the file but I got the same result. On the other hand, I am admin on the PC so I have permission for everything.

I have tried to open a new project and edit only a really small video but I noticed the same error.

Just to be really sure, you could try to run Shotcut as root using sudo. This would just just as a debugging test, not a solution.

I have managed to make the export with a little hack. I have checked the used “export” command in the Terminal and I have called it with the script (With the Linux way mlt path [Changed the %2F to / in the path]).

The root-cause is still not clear for me (Even why I don’t get any log of the exporting [or at least an error]) but now I am happy because I don’t need to throw my work to the trash.

I will do perform some more debugging, perhaps I can discover the root-cause of the problem. I will let you know if I have any update. Or if you have any clue what I should do, just le me know…

BTW, I have to say a big thanks to you guys. Your team members and your support is very quick and helpful. :slightly_smiling_face:

Yes it is strange and not common. Thanks for trying to help determine and glad you found a workaround. If you are running a locale that uses comma for a decimal point please set the environment variable LC_ALL=C when running melt from the command line.