False selected track after deleting a track

What is your operating system?
Linux Mint 19.3

What is your Shotcut version (see Help > About Shotcut)? Is it 32-bit?

There is a bug, when deleting a track e.g. under the latest existing track with clips.


Are you able to reproduce it ? I tried and tried adding more tracks and more clips every time and I couldn’t replicate the problem.

If you can reproduce it constantly, please tell us the steps.

Yes, reproducable…
E.g. from that picture above:

I deleted the first track (Track1) and added another as maybe Track 4 == selection false

(I saved the project temporary and opened it again…)
I deleted that new Track 4 == selection false

Is the selection false, or are the tracks scrolled in such a way that they aren’t aligned with the proper track heads? I am able to produce a scenario where I delete a track and the tracks go out of alignment with their track heads, but then I move the vertical scrollbar up and down, and they immediately realign.