Fails to open audio input

Hello,

First, I quite like this program. I’m just getting into video editing but Shotcut is wonderfully straightforward with no convoluted learning curve. I’m still getting the basics down but I’m glad this program exists.

That said, I can’t do any voice overs with it. I follow the steps… I have my project open, I go to Open Other > Audio/Video Device > Audio Input… I select my mic, which Shotcut sees, but all I get is the error "Failed to open dshow:audio=Microphone.

My version of Shotcut is up to date, my pc runs Windows 10 and the mic works on other devices, it works on the pc when I test it over the speakers but it just won’t open for Shotcut.

I’m thinking that it’s because the desktop is actually fairly old and it’s actually time for a new one. Maybe my mic, Shotcut and the RealTek audio just don’t get along but if there’s a way to fix this that’d be great because right now I’m recording voice overs on my cell phone and then transferring the file to my pc.

See https://github.com/mltframework/shotcut/issues/790 and see if you can add info I requested in my last comment.

Hmmm… It’s not an issue with Shotcut. My pc and mic don’t seem to like each other.

I saw your suggestion in that link to record with the built in Windows voice recorder so I opened it. It told me to go to settings and set up a mic. In settings it shows my mic, says it’s enabled and the default device but it won’t work with the Windows app either. With this pc, it only works when I’m testing it over the speakers and when I try to configure it the wizard fails to start and tells me to go back to settings… which tells me it’s enabled and… time for a new mic and/or pc it seems.

But thanks for replying. :slight_smile:

Oh god… so simple and should have been so obvious…

I just went into the Privacy settings for Windows and my wife had turned off the mic permissions… which is funny since we’ve never even used one with the pc before. I turned them back on and guess what? Yep, Shotcut opens the mic and I can do voice overs now. I almost gave up too but decided to click around a bit more.

Heh. Next time folks have a problem suggest they check their Windows Privacy settings.