Failed to Open

Hi Please help! I saw this problem passing by this forum before but there wasn’t a sollution offered (though they said they were gonna look for one. I’m here hoping a sollution has been found by now T_T)

I worked very long on this vid. I saved it a couple of times and it opened without issue. I went on a short vacation so I didn’t use my pc for a day or 2 and when I try to open it now it says “failed to open”.

Looking through the forum I did as suggested, I opened the Application Log and this is what it says:

I also opened it in Notebook ++ and all it says is NULL .

I’m really scared this file is a total loss. I worked on it off and on for a week. It would break my heart if I had to start practically from the beginning. I had a double accidentally saved, but that only has the intro. I wanted to finish this before I go on a 2 week trip in like a day or so. Please help?

This file is unrecoverable. You can look for a valid backup in Settings > App Data Directory > Show… > autosave. Sort the folder listing by Date Modified in reverse to find the most recent few. Maybe one of them is some version of your project.
Another possible solution is available if you have a backup system in place. Windows has a builtin versioning backup if you set it up.

What version are you using? I made a couple of changes in 2019 to try to avoid this bug, but I was never able to reproduce to know for sure the cause. Use Help > About Shotcut to get the version.

My version is 19.10.20 . I’ve only started working with this program since a couple of weeks. The autosave is empty so that’s a bust too. Thanks for the help either way.
I’m trying to see if I can find it with Recuva

That is strange. I went to great lengths to make changes to first write to a temporary file and verify its integrity before overwriting an existing file. So, I am at a loss how the file becomes all nulls. This problem has never happened to me while developing on Shotcut almost daily for 7 years. Sorry for your loss.

Unfortunately I guess I’m just special like that :cry:
Do you want some extra pics from the Application Log to see if you can find out what caused this?

I thought about this some more since someone else was just affected. I am thinking there could be two reasons outside of Shotcut since Shotcut now validates the file saved as valid XML (no NUL).

  1. Some security product zeroes a file after a deletion
  2. Something going wrong with disk write-back caching

I found this post from a NTFS developer supporting my second guess:

Some other reply gives a corrupt disk as a reason. More ideas and people facing this same problem while not using Shotcut can be found in a web search on “windows save nul”.

This topic was automatically closed after 90 days. New replies are no longer allowed.