Failed to open mlt file?

Hello! A file that i spent alot of time on is failing to open. My operating system is windows 11.

I’ve tried:

  • restarting shotcut
  • restarting the computer
  • re-installing the shotcut version before the latest one
    -re-installing the latest shotcut again
  • adding an exclusion to windows security (both shotcut and the mlt file in question)
  • checking for unusual characters in both the parent folder and file (ex: !/%*)

The only thing i can think of is that the mlt file source was moved at some point before saving? But i tried opening an earlier version of that file (separate save), and it opens just fine. Both THAT file AND the newer file are visible in theire respective locations, however, only the old version of the mlt file shows up in Recent Projects on the different versions of Shotcut. Its very inconsistent, though.

Any advice would be appreciated. I did try to solve the problem via googling other people having the same issue, but the solutions did not work for me (as referenced above). I would really, really prefer not to have to redo all the work again on the old version as it was several hours of work. :frowning:

To add, i have also checked the auto saved files. Nothing has auto saved, except for 2x unrelated files from about two months ago.

Can you upload your MLT file?
Just drag/drop into the reply window.
Your media is not needed.

NEWGanggang.mlt (27.5 KB)

Just did the drag and drop!

I found an issue, but not sure how to fix it. Perhaps someone else with MLT experience can fix it. NUL characters shouldn’t be there. Sometimes the whole file is damaged with NUL characters.


Even if you cant fix it, i feel like its one step closer to figuring it out.

Have you ever seen something like that before, or do you have any idea what can cause something like that?

This particular error I have not seen before.

It’s best to start using “Save As” to back up your work as you edit. Save As creates a new file of your current work with a new file name.

1 Like

For sure. Itll serve as a painful lesson, unless someone else has some magical solution. :')

Your mlt file had illegal characters and was malformed (with a partial incomplete duplicate at the bottom), so it was royally screwed. No guarantees, but this should open and give you something close to what you had (download the attached file and place it in the same directory as your original messed up file.

NEWGanggang_FIXED.mlt (15.8 KB)

Hopefully you are lucky this time around, but read this:

1 Like