Failed to open mlt after system shutdown unexpectedly

Ubuntu 20.04
Latest version of Shotcut

Wars.mlt (180 KB)

I have a 1tb lenovo that was shockingly running out of space while i was editing the video, which never happened before. I had over 200gb space on the laptop this morning before I began. Anyway, although shotcut kept crashing during the entire edit, the .mlt file would not fail to open even after the system shutdown once earlier. However, the second time when the system shutdown unexpectedly, Shotcut showed me a “failed to open file” error. I checked to see if I’d used any special characters while naming any of the files it is currently and all is good. please help me fix this if it is a bug

Edit 1: I tried fixing it based on the missing “” in the txt suggestion and I still cannot open it.

here’s the edited .mlt
Wars.mlt (180.1 KB)

I took a look at your MLT file. I’m not an expert, but I found at least two things that look wrong

In the top of the page, I noticed this:

These 2 numbers (33870000 and 1620049) look wrong.
In one of my project for example I have this

30 being the frame rate of my project.

At the end of your MLT page, there are obviously lines missing

Instead of this:

You should have AT LEAST this:

I changed the frame rate values in your file and added lines at the end and Shotcut no longer says Failed to open

But I doubt it is fixed. Chances are there are more lines missing at the end of your file,

You can try it anyway, just in case:
Wars_fix-attempt.mlt (180.0 KB)


Thanks but it is still not fixed. I can only see the final video not the rest 10 minutes of it all.