Failed to Open in Shotcut


#1

Hello,

I’ve been working on this project for 2 weeks now. I save early and often, I updated with the latest shotcut. Last night, the file says " failed to open" and in the notepad and word the white space is there but there is no text to even correct the corrupted file. If you could help , I would really appreciate it. Here is the file pasted below.

Thanks in advance!

WinterTimeVlog.mlt (81.5 KB)


#2

Not sure what you did to your file, but nothing is there. Probably when you edited it, you didn’t save it the right way. Might have tried to use windows Notepad for editing.

With Notepad++ your file looks like this:
notepad%20%20_2019-01-13_00-29-30
Saved in this format: notepad%20%20_2019-01-13_00-29-02

A normal mlt file looks like this with Notepad++
notepad%20%20_2019-01-13_00-29-56
Saved in this format: notepad%20%20_2019-01-13_00-28-48

Unless you have a backup copy, there isn’t anything to fix.


#3

This is the second time I have seen this bug reported (project file is all NUL characters). This is very unfortunate, but we have no idea yet what is the cause or how to cause it. It is very unlikely due to updating the Shotcut software; that is most likely a coincidence. In Windows, you can turn on Backups for the folder where you keep project files to try to make recovery possible. That is a strong recommendation for the documents and project folders on any computer OS.


#4

So, here’s a suggestion to Shotcut development.
When saving a project file (MLT file) it would be good if the existing one renamed.

For example the project file name is project.mlt

option 1.
When saving, Shotcut renames this existing file to project-“YYYYMMDD-HHMMSS”.mlt (where YYYYMMDD and HHMMSS are the date and time when the file was saved last time, it can be read from the filesystem; ex.: project-20190114-235933.mlt) AND then saves the very actual state of the project to the file project.mlt

option 2.
Shotcut saves the project at every save command into two files at once: project.mlt AND project-YYYYMMDD-HHMMSS.mlt where the YYYYMMDD and HHMMSS are the date and time of the system when the save command was launched.

IMHO option 2 is much easier…

OK, I see, that this can generate a big amount of files, BUT it can really prevent this “bug” (?) , as ALL the saved states can be found from the very beginning of the project. :wink:
And the user can delete the unneeded ones any time. :wink:

So, if the last saved state (project.mlt) get corrupted, then (all) the previous state(s) will be there, and it is very much better having a huge amount of previous saves then having just one project.mlt but full of NUL-s. :wink:

And… it might be an option in the settings if one want to turn this off…

Hmm? :slight_smile:


#5

Sorry, but I am not going to litter someone’s storage with a bunch of files by default! It could be a setting that is off by default, but I believe most people will not turn it on, and it might be difficult to tie the behavior to the name of the setting. I might add to the project folder feature an option around this including possibly integrating git.


#6

Thank you all so much for your efforts. I just went ahead and redid it. Lol man the hater bots on my computer can’t stop me! Check out my vlog at “Hoosierontherun” on YouTube. All those videos have been edited with Shotcut:)


#7

Ofcourse I understand and agree. :slight_smile:

So a plus idea for this: in this setting could be a number, which sets the number of the last files to keep.
For example, if that number is set to 13, then only the last 13 “project-YYYYMMDD-HHMMSS.mlt” files would be kept, any older wolud be deleted on every save command. :wink: